SNA Server Does Not Send ACTLU (ERP) After ACTPU (ERP) (811105)



The information in this article applies to:

  • Microsoft Host Integration Server 2000
  • Microsoft Host Integration Server 2000 SP1
  • Microsoft SNA Server 4.0 SP4

SYMPTOMS

After a connection outage, SNA Server and Host Integration Server 2000 may not reactivate any 3270 Dynamically Defined Dependent Logical Units (DDDLUs). Static-defined LUs do not have this problem.

CAUSE

After the connection outage, the SNA Server service may fail to send Network Management Vector Table (NMVT) (power-on) messages to elicit ACTLUs from the new SSCP for the DDDLU LUs after the receipt of the ACTPU error recovery protocol (ERP).

RESOLUTION

SNA Server 4.0

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next SNA Server 4.0 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version       Size     File name
   -------------------------------------------------------
   10-Jan-2003  13:56  4.0.0.606     468,864  Snaservr.exe     
   10-Jan-2003  13:56  4.0.0.606     935,856  Trcservr.exe
				
Note Because of file dependencies, the most recent fix that contains the previous files may also contain additional files.

Host Integration Server 2000

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Host Integration Server 2000. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

328152 How to obtain the latest service pack for Host Integration Server 2000

Hotfix information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version       Size       File name
   ---------------------------------------------------------
   10-Jan-2003  13:56  5.0.0.900     471,312    Snaservr.exe     
   10-Jan-2003  13:56  5.0.0.900     1,028,368  Trcservr.exe 
				
Note Because of file dependencies, the most recent fix that contains the previous files may also contain additional files.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

This problem was corrected in Microsoft Host Integration Server 2000 Service Pack 2.

Modification Type:MinorLast Reviewed:10/11/2005
Keywords:kbHotfixServer kbQFE kbQFE kbSNA400sp4fix kbhis2000fix kbfix kbbug KB811105 kbAudITPRO