Slow or Delayed Screen Updates After Reconnecting to Console Session (811080)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Professional SP1
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Home Edition SP1
  • Microsoft Windows XP 64-Bit Edition SP1

SYMPTOMS

After you connect to the console session on a Microsoft Windows XP-based computer by using the Remote Desktop client, screen updates may be delayed, and the computer may seem to be unresponsive. Right-clicking the desktop can force delayed updates to appear.

CAUSE

This problem should occur only if a specific Win32 function (EnumDisplaySettings) is called while a previous RDP session to the console is disconnected.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name  Platform   SP
   --------------------------------------------------------------------
   18-Dec-2002  19:03  5.1.2600.108    87,048  Rdpdd.dll  x86      none
   20-Dec-2002  21:55  5.1.2600.1152   87,304  Rdpdd.dll  x86         1
   18-Dec-2002  19:03  5.1.2600.108   259,976  Rdpdd.dll  IA64     none
   05-Dec-2002  01:28  5.1.2600.1148  261,128  Rdpdd.dll  IA64        1

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

MORE INFORMATION

When this problem occurs, the computer does not seem to be affected in any other way (for example, CPU usage is typical). You can clear the condition with an interactive logon (at the physical console).

To determine if this problem is occurring, start a command prompt and type some characters. If the problem is occurring, the characters appear only after you right-click the desktop.

The Microsoft Systems Management Server (SMS) Inventory agent uses the Win32_DisplayControllerConfiguration and Win32_VideoController WMI classes. These WMI classes use the affected function. Because the agent runs regularly in the background (as a service), it triggers the problem if a remote console session is left disconnected.

Modification Type:MinorLast Reviewed:10/11/2005
Keywords:kbHotfixServer kbQFE kbWinXPsp2fix kbQFE kbfix kbbug kbWinXPpreSP2fix KB811080 kbAudITPRO