XCCC: Exchange Clients Do Not Receive "New Mail" Notification Messages (811061)



The information in this article applies to:

  • Microsoft Exchange 2000 Enterprise Server
  • Microsoft Exchange 2000 Server
  • Microsoft Windows 2000 Advanced Server

SYMPTOMS

Exchange 2000 Server clients may not receive a notification message when new mail arrives.

CAUSE

This behavior may occur when all the following conditions exist:
  • Exchange 2000 Server is installed on a cluster server.
  • The Exchange 2000 Server is behind a firewall.
  • The firewall is not configured to permit Internet Protocol (IP) traffic from the cluster node.
This behavior occurs because all mail traffic, both to and from the Exchange 2000 Server, is passed by using the Exchange 2000 Server virtual server IP address. However, when a new mail notification is sent, it comes from the cluster node IP address.

WORKAROUND

To work around this issue, reconfigure the firewall to permit outbound traffic from the IP address of the cluster node.

Note The client does not reply to this packet so there does not have to be two-way communication.

MORE INFORMATION

The Information Store process (Store.exe) sends a User Datagram Protocol (UDP) packet for new mail notifications. However, because the Store process does not run on an Exchange virtual server but on the cluster node, the UDP packet is sent from the IP address of that node. If you fail over the cluster node, the data and Exchange 2000 Server virtual server configuration are moved to the Store process that is running on the other cluster server node. New mail notifications are sent from the IP address of that second cluster node.

For additional information about a similar issue with the Message Transfer Agent on a cluster server, click the following article number to view the article in the Microsoft Knowledge Base:

251318 XCON: Message Transfer Agent Uses Node IP Address Instead of Cluster IP Address


Modification Type:MinorLast Reviewed:10/26/2005
Keywords:kbemail kbClustering kbprb KB811061