XSL requests in Internet Explorer do not use the client-side cache correctly (811045)



The information in this article applies to:

  • Microsoft XML 3.0 SP3
  • Microsoft Internet Explorer version 6 for Windows XP SP1

SYMPTOMS

When Microsoft Internet Explorer retrieves an XML file as the result of a POST request, and that XML file includes an XSL style sheet that is available locally in the cache, the style sheet is not retrieved from the client-side cache. Instead, the style sheet is requested in full from the specified URL.

When Internet Explorer retrieves the XML file as the result of a GET request, this problem does not occur. The XSL file is retrieved from the client-side cache if a valid and current copy of the file is available.

CAUSE

By design, POST requests do not use the client-side cache because they typically contain form data and receive a dynamic response from the server. In the affected versions of Microsoft XML (MSXML), the subsequent GET request for the XSL file that is included in the XML file also does not check the client-side cache.

The problem does not occur if the outer request for the XML file is a GET request. If the request for the outer XML file is a POST request, the inner request that is generated for an embedded style sheet in the XML file is not retrieved from the cache even if it should be. This request for an embedded resource, or XSL file, is still a GET request, even if the containing resource, or XML file, is requested with a POST request.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version      Size       File name     Platform
   ----------------------------------------------------------------
   20-Nov-2002  22:56  8.20.9816.0  1,208,320  msxml3.dll    i386
   20-Nov-2002  22:54  8.20.9816.0     24,064  msxml3a.dll   i386
   20-Nov-2002  22:54  8.20.9816.0     43,520  msxml3r.dll   i386

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:10/11/2005
Keywords:kbHotfixServer kbQFE kbWebBrowser kbMSXML300fix kbPerformance kbQFE kbBug KB811045 kbAudDeveloper kbAudITPRO