The system may stop responding or you may receive an error message when you remove a mass storage device in Windows 98 Second Edition or Windows Millennium Edition (810900)



The information in this article applies to:

  • Microsoft Windows 98 Second Edition
  • Microsoft Windows Millennium Edition

SYMPTOMS

A computer that is running Microsoft Windows 98 Second Edition (SE) or Windows Millennium Edition may stop responding or you may receive an error message if you remove a mass storage device from a bus.

For example, the error may be a page-fault error and the mass storage device that you remove may be a USB device, a 1394 device, or a PCMCIA device.

Note This problem only occurs with devices that support commands that lock and unlock media.

CAUSE

This problem occurs when you remove a device too quickly because an unlock command is sent to a device that no longer exists.

In Windows 98 SE and in Windows Millennium Edition, if a storage device supports media locking and unlocking, Windows tries to lock the media of the storage device before Windows writes to the media. After the data has been written to the device, Windows issues a command to unlock the media. In these Windows operating systems, the I/O Supervisor (IOS) has a driver that tracks devices with removable media. This driver is named Voltrack.vxd. When this driver receives a request to unlock the media on a device, the driver does not immediately send the command to the device. Instead, the driver schedules a 5-second time-out. When the time-out expires, the driver sends the unlock request to the device.

If you remove a storage device immediately after you write a file to the device, you may have removed the device during the same time that the volume tracker driver (VolTrack.vxd) is waiting for the 5-second time-out to elapse. When the time-out occurs, the volume tracker sends an unlock command for a device that no longer exists. This condition causes the computer to stop responding or the error message.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MajorLast Reviewed:8/18/2005
Keywords:kbPlugPlay kbStorageDev kbUSB kbprb KB810900 kbAudEndUser kbAudITPRO kbAudOEM