Error message: Spooler subsystem app has encountered a problem and needs to close (810894)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you try to start or stop the Print Spooler service, or when you click Start and then click Printers and Faxes, you may receive the following error message:
Spooler subsystem app has encountered a problem and needs to close.
When you try to print, you may receive the following error message:
Operation cannot be completed.

CAUSE

This issue may occur if the correct installation and functionality of a newly installed printer is affected by an existing third-party printer driver or service.

For example, this issue may occur if the LexBCE custom printer driver from Lexmark is installed on your computer before you add another printer.

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
  1. Start the computer in Safe mode.

    For additional information about starting your computer in Safe mode, click Start, click Help and Support, type safe mode in the Search box, press ENTER, and then click the Start Windows in Safe mode topic.
  2. Start Windows Explorer, and then delete all files and folders in the following two folders:

    • c:\windows\system32\spool\printers
    • c:\windows\system32\spool\drivers\w32x86
  3. Click Start, click Run, type regedit in the Open box, and then press ENTER.
  4. Navigate to and then click the following registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environment\Windows NT x86

    View the list of subkeys. There should be only the following subkeys:
    • Drivers
    • Print Processors
  5. If there are any keys other than those listed in step 4, follow these steps:
    1. On the File menu, click Export.
    2. In the File Name box, type a descriptive name for this key -- for example, type WindowsNTx86regkey -- and then click Save.

      You can use this backup of the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environment\Windows NT x86 registry key to restore the key if you experience any problems after you complete this procedure.
    3. Delete all keys other than those listed in step 4 .
  6. Navigate to and then click the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors registry key. View the list of subkeys. There should be only the following subkeys:
    • BJ Language Monitor
    • Local Port
    • PJL Language Monitor
    • Standard TCP/IP Port
    • USB Monitor
  7. If there are any keys other than those listed in step 6, follow these steps:
    1. On the File menu, click Export.
    2. In the File Name box, type a descriptive name for this key -- for example, type WindowsNTx86regkey -- and then click Save.

      You can use this backup of the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors registry key to restore the key if you experience any problems after you complete this procedure.
    3. Delete all keys other than those listed in step 6.
  8. Disconnect the printer cable from the computer, and then restart the computer.
  9. Reconnect the printer cable to the computer, install the printer according to the manufacturer's installation instructions, and then try to print a test page.

MORE INFORMATION

Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.
The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:9/15/2004
Keywords:kberrmsg kbprb KB810894