The primary advertised program does not run when it depends on another program in SMS 2.0 (810867)



The information in this article applies to:

  • Microsoft Systems Management Server 2.0 SP4

SYMPTOMS

When a Microsoft Systems Management Server (SMS) 2.0 client receives an advertisement for a program that depends on another program, the advertised program may never run. This behavior occurs even though the dependent program runs repeatedly on the client.

CAUSE

This problem may occur if the advertised program and the dependent program are configured to run under different conditions from each other. For example, program A is set to run Only when a user is logged on, and this program depends on program B. Program B is set to Run once for every user.

This problem may also occur in the following scenario:
  1. You configure program A with the following properties:
    • Runs whether or not a user is logged on
    • Runs with administrative rights
    • Depends on Program B
  2. You configure program B with the following properties:
    • Requires a user to be logged on
    • Runs with the logged on user's permissions
  3. You advertise program A to a collection of SMS clients as a mandatory advertisement.
Typically, in this scenario, the SMS client runs program B first and then runs program A. However, if a user is not logged on to the computer, the Advertised Programs Manager (SMSAPM) tries to run program A, but SMSAPM detects that the dependent program B must run first. Because program B requires a user to be logged on, the following error is logged repeatedly in the SMSAPM32.log file:
Sleeping. Trying to get PEA IPC server in 1 sec.
Because program A is the primary advertised program, it receives a "failed" error condition. When a user logs on to the computer, program B runs as expected, but program A never runs.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for SMS 2.0. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

288239 How to obtain the latest Systems Management Server 2.0 service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next SMS 2.0 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have SMS 2.0 Service Pack 4 (SP4) installed to apply this hotfix.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   06-Jan-2003  12:29  2.0.4.1           254,103  Q810867.exe      
   01-May-2002  15:55  2.0.92.9          638,676  Apasetup.exe     Alpha
   01-May-2002  14:55  2.0.1493.4163     295,184  Ccim32.dll       Alpha
   01-May-2002  15:30  2.0.92.9        1,926,769  Ccmcore.exe      Alpha
   01-May-2002  15:30  2.0.1493.4170   4,453,167  Clicore.exe      Alpha
   01-May-2002  09:05  2.0.1493.4105     125,712  Clisvcl.exe      Alpha
   01-May-2002  15:30  2.0.1493.4170      13,584  Cliver.exe       Alpha
   01-May-2002  12:45  2.0.1493.4149      55,056  Cqmgr32.dll      Alpha
   01-May-2002  13:30  2.0.1493.4146      75,536  Odpsys32.exe     Alpha
   01-May-2002  13:30  2.0.1493.4146      83,216  Odpusr32.exe     Alpha
   01-May-2002  15:55  2.0.1493.4175     331,536  Smsapm32.exe     Alpha
   01-May-2002  15:30  2.0.92.9          694,839  Swdist32.exe     Alpha
   01-May-2002  15:55  2.0.92.9          391,449  Apasetup.exe     x86
   01-May-2002  14:55  2.0.1493.4163     182,096  Ccim32.dll       x86
   01-May-2002  15:30  2.0.92.9        1,324,792  Ccmcore.exe      x86
   01-May-2002  15:30  2.0.1493.4170   3,409,548  Clicore.exe      x86
   01-May-2002  09:05  2.0.1493.4105      88,432  Clisvcl.exe      x86
   01-May-2002  15:30  2.0.1493.4170       8,512  Cliver.exe       x86
   01-May-2002  12:45  2.0.1493.4149      34,656  Cqmgr32.dll      x86
   01-May-2002  13:30  2.0.1493.4146      54,128  Odpsys32.exe     x86
   01-May-2002  13:30  2.0.1493.4146      60,784  Odpusr32.exe     x86
   25-Sep-2001  20:14  2.0.1250.7        762,688  Preinst.exe      x86
   01-May-2002  15:55  2.0.1493.4175     252,784  Smsapm32.exe     x86
   01-May-2002  15:30  2.0.92.9          640,802  Swdist32.exe     x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:4/14/2006
Keywords:kbQFE kbHotfixServer kbClient kbSMSAppMan kbSMS200preSP5fix kblogin kbUser kbfix kbBug kbSoftwareDist kbPackage kbAdvertisement KB810867 kbAudITPRO