Many Event ID 772 Entries Are Recorded with HP SecurePath Software (810637)



The information in this article applies to:

  • Microsoft Windows 2000 Server SP3
  • Microsoft Windows 2000 Advanced Server SP3
  • Microsoft Windows 2000 Professional SP3
  • Microsoft Windows 2000 Datacenter Server SP3

SYMPTOMS

Many event ID 722 entries may be recorded in the system event log. These entries may occur if you are running Windows 2000 Service Pack 3 (SP3) with certain versions of the HP SecurePath software in combination with some HP storage systems. An event ID 722 entry indicates a path failover, but file read and write operations on the disks that are managed by SecurePath typically work correctly in this case.

The event ID 772 entries may be generated at various rates. In one observed test, a 32-MB system event log was filled with event ID 772 entries in less than 30 seconds.

The following table lists the affected versions of SecurePath on the indicated HP storage systems.
Storage systemSecurePath version
RA41003.1A for Windows Workgroup Edition
RA41003.1X for Windows Workgroup Edition
MSA 1000 * 3.1B for Windows Workgroup Edition
MSA 1000 * 4.0 for Windows Workgroup Edition
* (firmware revision 1.16 or earlier)

CAUSE

The affected versions of the SecurePath software and HP storage systems misinterpret the SCSI "SYNCHRONIZE CACHE" command to mean that a path has stopped working. This causes the SecurePath software to fail over to the alternate path. This failover results in the event ID 772 entry.

There is a problem in versions of Windows 2000 before SP3 that prevent the SCSI "SYNCHRONIZE CACHE" command from being sent when they are expected (as the result of a command by a program or an upper-level driver). This problem was corrected in the hotfix that is documented in the following Microsoft Knowledge Base article:

281672 Possible Data Loss After You Enable the "Write Cache Enabled" Feature

This fix was included in Windows 2000 SP3.

Windows 2000 Service Pack 2 (SP2), without the 281672 hotfix, does not experience this problem because the SCSI "SYNCHRONIZE CACHE" command is not issued.

RESOLUTION

To resolve this problem, use one of the following methods as appropriate:
  • If you are using SecurePath for Windows Workgroup Edition version 3.1B or 4.0 with the MSA 1000 storage system (with firmware revision 1.16 or earlier), obtain an MSA 1000 firmware update and a SecurePath software update from HP. This update was released by HP in December, 2002.
  • If you are using SecurePath for Windows Workgroup Edition version 3.1A or 3.1x with the RA4000 or RA4100 storage system, obtain an updated Host Bus Adapter (HBA) driver from HP. This update is expected to be available from HP near the end of January, 2003.

MORE INFORMATION

To see an HP customer advisory about this issue, visit the following HP Web site: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:2/27/2003
Keywords:kb3rdparty kbprb KB810637 kbAudOEM kbAudITPRO