Windows Media Player Cannot Play Streaming Media If There Are Two Remote Access Connections (810635)



The information in this article applies to:

  • Microsoft Internet Explorer 6.0 SP1, when used with:
    • the operating system: Microsoft Windows XP
    • the operating system: Microsoft Windows 2000
    • the operating system: Microsoft Windows NT 4.0
    • the operating system: Microsoft Windows 98 Second Edition
    • the operating system: Microsoft Windows Millennium Edition
    • the operating system: Microsoft Windows 98

SYMPTOMS

If you are using multiple remote access connections, Microsoft Windows Media Player may not be able to play streaming media.

CAUSE

Windows Media Player uses the Wininet InternetGetConnectedStateEx function to detect remote access connections and local area network (LAN) connections. However, the function cannot detect the remote access connection correctly if there are multiple remote access connections. If you have multiple remote access connections running, Windows Media Player may detect that your computer is offline.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Internet Explorer 6 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version        Size     File name
-------------------------------------------------------
14-Mar-2003  18:00  6.0.2800.1175  585,728  Wininet.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:10/11/2005
Keywords:kbHotfixServer kbQFE kbIE600preSP2fix kbfix kbbug KB810635