You Are Prompted to Type a Password After You Upgrade to Windows XP (810605)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

SYMPTOMS

After you upgrade from Microsoft Windows Millennium Edition or Microsoft Windows 98 to Windows XP, you may be prompted to log on by typing a password. This symptom may occur even if no password previously existed or was specified during the upgrade process. When this occurs, you may not be able to log on, regardless of the password you type.

CAUSE

This issue may occur if Windows XP Setup created a random password during the upgrade that was assigned to one or more user accounts. This password is stored in the Setupact.log file.

RESOLUTION

To resolve this issue, remove the password that was created during the upgrade:
  1. Restart your computer, and then start the Recovery Console. For additional information about how to use the Recovery Console, click the following article number to view the article in the Microsoft Knowledge Base:

    314058 Description of the Windows XP Recovery Console

  2. At the command prompt, type cd \windows, and then press ENTER.
  3. At the command prompt, type type setupact.log, and then press ENTER. Search the Setupact.log file for the "Random password for Username is xxxxxxxxxxxx" entry, where Username is the name of the account and xxxxxxxxxxxx is the current password for the account.
  4. Note that passwords are case sensitive. Write down this password, search the rest of the file, and write down all other passwords that you find.
  5. After you search the Setupact.log file, type exit, and then press ENTER.
  6. Restart your computer, and then use the password you noted to log on to Windows XP.
  7. Reset the password on your user account.

Modification Type:MajorLast Reviewed:12/10/2002
Keywords:kbui kbprb KB810605