SYMPTOMS
When you make two consecutive calls to the
Interchange.SubmitSync() method, the second call fails and the following error
message is returned by the call:
C0C0013F, "THE
SERVER COULD NOT FINISH PROCESSING THE DOCUMENT"
When this
error occurs, an error similar to the following is written to the BizTalk
Server application log:
An error occurred in
BizTalk Server.
Details: The XML document has failed validation for the
following reason:
The element "testelement" is used but not declared in
the DTD/Schema.
The server could not finish processing the
document.
CAUSE
This error will occur under the following
conditions:
- The first call to the Interchange.SubmitSync() method
references a channel that is associated with a document definition that
references a valid document specification
- The second call to the Interchange.SubmitSync() method
references a channel that is associated with a document definition that does
not reference a valid document specification
When this occurs, the second call to the
Interchange.SubmitSync() method will still reference the document specification
from the first call to the Interchange.SubmitSync() method and cause the error
listed above.
This behavior is changed in the Service Pack/hot fix
referenced below so that calls to the SubmitSync() method will not reuse a
previously referenced document specification if the channel being referenced in
the SubmitSync() call is not associated with a document definition that
references a valid document specification.
RESOLUTION
Service Pack Information
To resolve this problem, obtain
the latest service pack for Microsoft BizTalk Server 2002. For additional
information, click the following article number to view the article in the
Microsoft Knowledge Base:
815781 INFO: How to Obtain the Latest BizTalk Server 2002 Service Pack
Hotfix Information
A supported fix is now available from
Microsoft, but it is only intended to correct the problem described in this
article. Only apply it to systems that are experiencing this specific problem.
This fix may receive additional testing to further ensure product quality.
Therefore, if you are not severely affected by this problem, Microsoft
recommends that you wait for the next service pack that contains this hotfix.
To resolve this problem immediately, contact Microsoft Product
Support Services to obtain the fix. For a complete list of Microsoft Product
Support Services phone numbers and information about support costs, visit the
following Microsoft Web site:
Note In special cases, charges that are ordinarily incurred for
support calls may be canceled if a Microsoft Support Professional determines
that a specific update will resolve your problem. The usual support costs will
apply to additional support questions and issues that do not qualify for the
specific update in question.
The English version of this
fix has the file attributes (or later) that are listed in the following table.
The dates and times for these files are listed in coordinated universal time
(UTC). When you view the file information, it is converted to local time. To
find the difference between UTC and local time, use the
Time
Zone tab in the Date and Time tool in Control Panel.
Date Time Version Size File name
------------------------------------------------------
22-Nov-2002 21:10 3.0.1552.0 131,344 Cisapi.dll
22-Nov-2002 21:10 3.0.1552.0 524,560 Ciscore.dll
22-Nov-2002 21:10 3.0.1552.0 405,776 Cisengine.dll
22-Nov-2002 21:10 3.0.1552.0 348,432 Mscis.exe