XADM: Mailbox Store Grows When You Replicate Public Folders from Exchange Server to Exchange 2000 (810342)



The information in this article applies to:

  • Microsoft Exchange 2000 Server
  • Microsoft Exchange Server 5.5

SYMPTOMS

When you replicate public folder data from Exchange Server to Exchange 2000, the mailbox store on the Exchange 2000 server may grow, even if no mailboxes reside on the Exchange 2000 server. The Exchange 2000 mailbox store may grow to be as large as two-thirds the size of the public folder store.

CAUSE

This behavior occurs because you are replicating large amounts of public folder data. Public folder replication messages are sent as e-mail system messages in both Exchange Server and Exchange 2000. Because e-mail communication between Exchange Server and Exchange 2000 requires legacy message transfer agent (MTA) or X.400 support, these messages must be converted to the Simple Mail Transfer Protocol (SMTP) format that is used by Exchange 2000. Content conversion is completed by using a hidden folder in the mailbox store.

For additional information about how the MTA handles mail flow, click the following article number to view the article in the Microsoft Knowledge Base:

263248 XCON: X.400 Message Flow in Exchange 2000

If you are replicating large amounts of public folder data, the mailbox store grows to convert and store the replication e-mail messages. Latency during content conversion of a large number of e-mail messages, combined with database fragmentation, can also contribute to large mailbox store sizes.

Note Exchange 2000 can send replication messages directly from one public store to another and bypass the mailbox store.

Additionally, the mailbox store contains the replication storage table, which grows during replication. The replication storage table acts a temporary storage area while the item waits to be delivered to the public store. Online defragmentation tries to empty this table, but as the database grows, the online defragmentation maintenance window may not be large to enough to empty the table. This can prevent the database from reducing in size, and the online defragmentation process starts over in the next window, which compounds the initial problem.

WORKAROUND

To work around this behavior, use one of the following options:
  • Increase the online maintenance window, which permits the online defragmentation to complete and reduces the overall size of the mailbox store. For additional information about how to increase Exchange maintenance windows, click the following article number to view the article in the Microsoft Knowledge Base:

    244524 XADM: How to Configure the Exchange Server Online Defragmentation Time

  • Complete an offline defragmentation. For additional information about how to complete an offline defragmentation, click the following article number to view the article in the Microsoft Knowledge Base:

    328804 XADM: How to Defragment Exchange 2000 Server Databases

  • Reduce the public folder data that is being replicated at one time by selecting fewer folders to replicate. For example, if you are currently replicating 100 GB of total data, modify replication so that only a subset of the public folders are replicated at one time. After replication has occurred, let online maintenance run overnight, and then replicate a different subset of folders the next day. Repeat this process until all data has been replicated.

STATUS

This behavior is by design. This behavior can depend on the public folder data that is being replicated.

MORE INFORMATION

Do not remove the mailbox store object from the Exchange 2000 public folder server to work around this behavior. The mailbox store is required for content conversion. If you remove the mailbox store object, replication messages will not be handled correctly, and other complications may occur.

Modification Type:MinorLast Reviewed:6/13/2003
Keywords:KB810342 kbAudITPRO