PRB: Error Message: The Catalog Schema Does Not Correspond to This Version of Commerce Server 2002 (810234)



The information in this article applies to:

  • Microsoft Commerce Server 2002

SYMPTOMS

After you upgrade from Commerce Server 2000 to Commerce Server 2002, and then you try to gain access to a catalog through the Business Desk (BizDesk) or a through a commerce site, you may receive the following error message:
The catalog schema does not correspond to this version of Commerce Server 2002.

CAUSE

This problem has two possible causes:
  • The catalog database has not been upgraded to Commerce Server 2002.

    -or-
  • An error occurred during the unpup operation.

RESOLUTION

To resolve this problem, do one of the following:
  • Upgrade the catalog database to Commerce Server 2002 by using the Upgrade Resource tool (CS2002Upgrade.exe). This tool is located in the \Program Files\Microsoft Commerce Server 2002\Upgrade folder.

    -or-
  • View the Pup.log file to determine if any errors occurred during the unpup operation.

MORE INFORMATION


To view the Commerce Server 2002 Upgrade Guide, visit the following Microsoft Web site:

Steps to Reproduce the Behavior

You may receive the error message in the "Symptoms" section when you unpack the site. To unpack the site, follow these steps:
  1. Download the Commerce Server solution sites. To do this, visit the following Microsoft Web site:
  2. Install the solution sites. For more information, visit the following Microsoft Web site:
  3. Unpack the solution sites. For more information, visit the following Microsoft Web site:
  4. Make changes to the catalog. For example, create a new catalog.
  5. Pack the site. For more information, see the Commerce Server documentation.
  6. Unpack the site.

Modification Type:MinorLast Reviewed:4/29/2003
Keywords:kberrmsg kbpending kbprb KB810234 kbAudDeveloper kbAudITPRO