"This Device Cannot Find Enough Free Resources" Error Message After You Install Gemplus PCMCIA 400 Smart Card Reader (810186)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Tablet PC Edition

SYMPTOMS

After you connect a Gemplus PCMCIA 400 smart card reader to a Windows XP-based Toshiba portable computer, Windows XP may be unable to initialize the device. Device Manager may list the device with a yellow exclamation mark. You receive the following error message when you view the device properties in Device Manager:
This device cannot find enough free resources that it can use. If you want to use this device, you will need to disable one of the other devices on this system. (Code 12)
This issue may occur with any of the following Toshiba portable computers:
  • Portege 2000
  • Portege 4000
  • Portege 3500 Tablet PC

CAUSE

During installation of the Gemplus drivers, Windows XP uses information contained in the Smartcrd.inf and Gempcc.inf files (provided with the Gemplus reader) to install and initialize the smart card reader. These configuration files contain information such as hardware interrupts and memory input/output (I/O) ranges that the device can use. The conflict occurs because the Smartcrd.inf and Gempcc.inf files list resources that are already in use by hardware components of the Toshiba products listed in the "Symptoms" section.

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Service Pack that contains this fix.

To resolve this problem immediately, download the fix by clicking the download link later in this article or contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site: Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:9/30/2005
Keywords:kbHotfixServer kbQFE kbfix kberrmsg KB810186