The event sink does not fire as expected on a computer that has both Exchange 2000 SP2 and ScanMail for Exchange version 6 installed (810150)



The information in this article applies to:

  • Microsoft Exchange 2000 Server

SYMPTOMS

Consider the following scenario. You bind one of the following items to a folder that is located in a user's mailbox in Microsoft Exchange 2000 Server:
  • An Exchange Mobility Event Sink
  • Any store event sink
Then, you use a rule to move incoming messages to a specific folder. In this scenario, the event sink does not fire.

Note This problem occurs after you install Microsoft Exchange 2000 Server Service Pack 2 (SP2)

CAUSE

This problem occurs because of an issue that occurs when Exchange 2000 Server SP2 and Trend Micro ScanMail for Exchange version 6 are installed on the same computer.

For example, if you follow these steps in the order that they are presented, ScanMail for Exchange version 6 scans the message as expected:
  • You install Exchange 2000 Server SP2.
  • You set up an event sink on the store.
  • You install ScanMail for Exchange version 6 on the Exchange 2000 Server SP2 server.
However, the event sink does not fire.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange 2000 Server service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites


This hotfix has the following prerequisites:
  • You must be running Microsoft Exchange 2000 Server Service Pack 3 (SP3) on the computer.

    For more information, click the following article number to view the article in the Microsoft Knowledge Base:

    301378 How to obtain the latest Exchange 2000 Server service pack

  • You must have the August 2004 Exchange 2000 Server post-Service Pack 3 update rollup installed.

    For more information, click the following article number to view the article in the Microsoft Knowledge Base:

    870540 Availability of the August 2004 Exchange 2000 Server post-Service Pack 3 update rollup

Restart requirement

You do not have to restart your computer after you apply this hotfix. However, the Microsoft Exchange Information Store service and its dependent services are automatically restarted during the hotfix installation.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

Hotfix file information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date        Time  Version     Size       File name 
   ---------------------------------------------------
   13-Sep-2004 04:47 6.0.6617.6  2,310,144  Mdbmsg.dll 
   12-Sep-2004 05:02 6.0.6617.6  4,685,824  Store.exe

MORE INFORMATION

For more information about Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

For more information about this issue, click the following article number to view the article in the Microsoft Knowledge Base:

327829 Event sink does not fire if you use ScanMail for Exchange

For information about how to contact Trend Micro, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and software vendor contact information, A-K

60781 Hardware and software vendor contact information, L-P

60782 Hardware and software vendor contact information, Q-Z

Author: jeffat
Writer:
Tech Reviewer: jeffat
Editor: v-michsh

Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbfix kbExchange2000preSP4fix kbbug kbHotfixServer kbQFE KB810150