Error Message Occurs with Damaged RAM or if the Fastfat.sys File Is Damaged or Missing (810091)



The information in this article applies to:

  • Microsoft Windows 2000 Professional

SYMPTOMS

When you start your computer, you may receive the following error message:
Windows could not start because the following file is missing or corrupt: System32\Drivers\FastFAT.sys

CAUSE

This issue may occur if either of the following conditions exist:
  • The Fastfat.sys file is damaged or missing.
  • The RAM in your computer is damaged or is not installed correctly.

RESOLUTION

To resolve this issue:
  1. Make sure that the RAM in your computer is not damaged and is installed correctly:

    Warning In the following procedure, you will remove RAM from your computer. Do not complete this procedure unless you are very familiar with the correct precautions to use when you remove internal computer hardware components. The internal components of some computers may be damaged by static electricity discharge, use of too much force for removal or insertion, or the use of inappropriate tools. Microsoft recommends that you contact a qualified technician for repair of internal computer components. For information about the correct handling of computer components, contact your computer manufacturer. For information about how to contact your hardware manufacturer, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

    65416 Hardware and Software Third-Party Vendor Contact List, A-K

    60781 Hardware and Software Third-Party Vendor Contact List, L-P

    60782 Hardware and Software Third-Party Vendor Contact List, Q-Z

    1. Turn off your computer.
    2. Remove the memory modules that are installed in your computer, but leave enough RAM for your computer to start and run Windows. For additional information about the Windows RAM requirements, click the following article number to view the article in the Microsoft Knowledge Base:

      304297 System Requirements for Microsoft Windows Operating Systems

    3. Start your computer. If you still receive the error message that is described in the "Symptoms" section of this article, remove a different memory module. You may have to restart your computer several times to identify the specific memory module that is not working correctly.
    4. If you determine that one or more memory modules are damaged, replace the damaged RAM, and then test to determine if the issue is resolved. If the issue is resolved, do not complete the remaining steps. If the issue is not resolved or you determine that none of your memory modules are damaged, go to step 2.
  2. Important If your computer is using the NTFS file system, you cannot use the following procedure to expand the Fastfat.sys file. Instead, you must create a parallel installation of Windows 2000. For additional information about how to create a parallel installation of Windows 2000, click the following article number to view the article in the Microsoft Knowledge Base:

    266465 HOW TO: Perform a Parallel Installation of Windows 2000

    Start your computer by using a startup disk that contains drivers for your CD-ROM drive. For example, you can use a startup disk from a computer that is running Microsoft Windows 98 or Microsoft Windows Millennium Edition.
  3. At the command prompt, type cd c:\winnt\system32\drivers, and then press ENTER.
  4. Type dir fastfat.sys, and then press ENTER. If you receive a "File not found" message, go to step 6. If you do not receive a "File not found" message, go to the next step.
  5. Type ren fastfat.sys fastfat.old, and then press ENTER.
  6. Type CD-ROM drive letter:, and then press ENTER.
  7. Type cd i386, and then press ENTER.
  8. Type expand.exe fastfat.sy_ c:\winnt\system32\drivers\fastfat.sys, and then press ENTER.
  9. Type c:, and then press ENTER.
  10. Restart your computer.

MORE INFORMATION

For more information about how to troubleshoot your Windows 2000 installation, visit the following Microsoft Windows 2000 Resource Kit Web site:

Modification Type:MajorLast Reviewed:3/17/2006
Keywords:kberrmsg kbprb KB810091