Active RPC Connections Are Closed (810008)



The information in this article applies to:

  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional

SYMPTOMS

If you use a remote procedure call (RPC) to communicate with a remote application, you may see active connections end. In your client application you may see the following error messages:

800706be
-or-
800706ba

CAUSE

The active connections are killed by the server that aborts a connection. This causes the client to kill all connections that are associated with the remote port. You can view this issue. Run a Microsoft Network Monitor trace and then review that trace. You can see the server abort a single connection, and then the client ends all connections to the same application on the server.

RESOLUTION

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

260910 How to Obtain the Latest Windows 2000 Service Pack

Hotfix Information

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
  Date         Time   Version              Size    File name
 ---------------------------------------------------------
01-Nov-2002  12:22  5.0.2195.6089     943,376    Ole32.dll
01-Nov-2002  12:22  5.0.2195.6112     429,840    Rpcrt4.dll
01-Nov-2002  12:22  5.0.2195.6089     184,592    Rpcss.dll

				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Windows 2000 Service Pack 4.

MORE INFORMATION

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:

265173 The Datacenter Program and Windows 2000 Datacenter Server Product

For additional information about how to install multiple hotfixes with only one reboot, click the following article number to view the article in the Microsoft Knowledge Base:

296861 Use QChain.exe to Install Multiple Hotfixes with One Reboot


Modification Type:MinorLast Reviewed:10/10/2005
Keywords:kbHotfixServer kbQFE kbnetwork kbWin2kSP4fix kbWin2000sp3fix kbWin2000preSP4Fix kbWin2000PreSP3Fix kbfix kbbug KB810008 kbAudITPRO