Cannot Close Files After UPS Service Warning Message (64487)
This article was previously published under Q64487
SYMPTOMS
After a power failure occurs on an uninterruptible power supply (UPS)
protected server, this message appears at the workstation:
A power failure has occurred at \\SERVER1. Please
terminate all activity with this server.
Attempting to save open files fails and an error message appears,
indicating that the path is no longer available.
CAUSE
The power failure message is sent to all session connected workstations,
MESSDELAY seconds after power is lost. Then, unless the UPS has the
capability to inform the server of a low-power state (see note below),
the UPS server stops the SERVER service BATTERYTIME seconds after the
point of initial power loss.
MESSDELAY defaults to 5 seconds and BATTERYTIME defaults to 60 seconds.
Thus, by default, all files must be closed within 55 seconds of receiving
the warning message. If the files are not closed within (BATTERYTIME
minus MESSDELAY) seconds from the initial power failure warning, you then
cannot close the files because the server service has stopped.
RESOLUTION
When the server service is properly stopped, as it is when it is stopped
by the UPS service, all open files are safely closed in the state they
were in when they were last saved.
Using a NET USE command at the workstation shows that connections to the
stopped server are in a "disconnected" state. After power returns and the
server service is restarted, workstation application files can be closed
safely.
Modification Type: |
Major |
Last Reviewed: |
11/21/2002 |
Keywords: |
kbnetwork KB64487 |
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