Metadirectory Corruption Occurs on a Replica Client (332198)



The information in this article applies to:

  • Microsoft Metadirectory Services 2.2 SP1
  • Microsoft Metadirectory Services 2.2

This article was previously published under Q332198

SYMPTOMS

When you run a replication agreement, an error message that is similar to the following sample error message may be logged in the Replication log in the \\Zoomserv\Data\Logs folder:
[31045]-New replica [cn=Andrew Dixon,ou=Sales,ou=Domestic,dc=NorthWindTraders,dc=com]

Bad protocol option-0
Read result (24021) for <cn=Karen Friske,ou=Sales,ou=Domestic,dc=NorthWindTraders,dc=com>
[31046]-Error 24021 synchronizing [cn=Karen Friske,ou=Sales,ou=Domestic,dc=NorthWindTraders,dc=com]

[31047]-New replica [cn=Andrew Dixon,ou=Sales,ou=Domestic,dc=NorthWindTraders,dc=com]
On the replica client, all objects that are located at the same structural level that are processed after the "Bad protocol" error message occurs are corrupted. Generally, some or all of the object's attribute values should be assigned to the next object. However, in the sample log that is listed earlier in this article, changes from the replica master that are destined for the Karen Friske object are applied to the Andrew Dixon object instead.

CAUSE

This problem occurs because Replica.exe does not flush its input buffers when the protocol error occurs.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Metadirectory Services 2.2 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site: Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Size       File name
---------------------------------------------
03-Jan-2002  16:37    175,104  Cdir_ad.dll
20-May-2002  14:01  1,015,296  Cdir_ex.exe
12-Jul-2002  13:50  1,031,680  Cdir_ldp.exe
05-Nov-2002  15:06  1,018,368  Cdir_ln.exe
20-May-2002  14:01  1,060,864  Cdir_nt.exe
20-May-2002  14:01    998,400  Cdir_nw.exe
20-May-2002  14:01    987,648  Cdir_vns.exe
05-Nov-2002  15:06    964,096  Importt.exe
20-Sep-2001  16:41     26,624  LdapSchema.dll
05-Nov-2002  15:06  1,039,872  Replica.exe
22-Apr-2002  09:04  1,030,656  VIACompact.exe
25-Sep-2002  17:09    997,888  Zscript.exe

Modification Type:MinorLast Reviewed:10/5/2005
Keywords:kbHotfixServer kbQFE kbfix kbBug kbMMS220preSP2fix KB332198