Send Requests Are Not Processed on SMS Child Primary Sites (331245)



The information in this article applies to:

  • Microsoft Systems Management Server 2.0

This article was previously published under Q331245

SYMPTOMS

When you monitor a Systems Management Server (SMS) 2.0 child primary site, there may be a backlog of Send Requests with an invalid status. These orphaned Send Requests are never processed by the SMS Scheduler or SMS Sender components. This may cause a backlog of Send Requests.

CAUSE

The SMS Scheduler component creates Send Requests identified in Routing Requests (RTR files) received from another SMS site. If a Send Request file with the same file name already exists in the SMS\inboxes\schedule.box\receive folder, the Routing Request is not processed.

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next service pack that contains this fix.

To resolve this problem immediately, download the fix by clicking the download link later in this article or contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site: Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
The Service Pack 5 (SP5) version of this fix will have the following files attributes or later:
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   19-Mar-2003  16:03  2.0.4.1           252,677  Sms2.0-kb331245-sp5-x86-enu.exe  
   25-Feb-2003  14:15  2.0.1493.5104   2,498,320  Basesvr.dll      Alpha
   25-Feb-2003  14:15  2.0.1493.5104   1,625,504  Basesvr.dll      X86
   25-Sep-2001  23:14  2.0.1250.7        762,688  Preinst.exe      X86
The Service Pack 4 (SP4) version of this fix will have the following files attributes or later:
   Date         Time   Version            Size    File name
   --------------------------------------------------------------

   20-Nov-2002  19:46  2.0.4.1           252,910  Q331245.exe      
   01-May-2002  17:40  2.0.1493.4160   2,435,856  Basesvr.dll      Alpha
   15-Sep-2001  11:00  2.0.1493.4000     127,248  Cmprov.dll       Alpha
   01-May-2002  12:05  2.0.1493.4105     145,680  Colleval.dll     Alpha
   01-May-2002  12:05  2.0.1493.4105     171,792  Compmgr.exe      Alpha

   01-May-2002  17:40  2.0.1493.4160   1,583,008  Basesvr.dll      X86
   15-Sep-2001  11:00  2.0.1493.4000      82,064  Cmprov.dll       X86
   01-May-2002  12:05  2.0.1493.4105      91,024  Colleval.dll     X86
   01-May-2002  12:05  2.0.1493.4105     121,440  Compmgr.exe      X86
   01-May-2002  17:10  2.0.1493.4154     830,224  Preinst.exe      X86
After the fix is installed, the SMS Scheduler component checks the Send Request IDs submitted by each new Routing Request and compares the ID against the current working list at the site. If the SMS Scheduler finds any matches, it assumes that there is a duplication and does not process any of the Send Requests received. The received Routing Request file is left intact and is re-evaluated on the next processing cycle.

WORKAROUND

To work around this problem, rename the failed Send Request file-name extension as .srs. The Send Request file can be processed after you change the original file-name extension from .srq to .srs. SMS Scheduler can then generate the file name specified in the received Routing Request file.

To determine which file to rename, review the Sched.log file on the site server. Note the Send Request IDs that appear before the following log entry:

Give slave send Request %s to the job manager, the destination site is %s
Cannot give slave send request to the job manager.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

In SMS hierarchies that use fan-out distribution, Routing Request files are received by mid-tier sites that act as the routing site between the source and target sites. The Routing Request contains the name of the Send Request file. If the Send Request file name already resides in the SMS\inboxes\Schedule.box\Requests folder, the Send Request may be orphaned and therefore never processed.

Modification Type:MinorLast Reviewed:4/14/2006
Keywords:kbQFE kbHotfixServer kbPerformance kbfix kbbug KB331245