Authentication Does Not Succeed When the User Name Contains a Space (331070)



The information in this article applies to:

  • Microsoft Internet Security and Acceleration Server 2000

This article was previously published under Q331070

SYMPTOMS

When Internet Security and Acceleration (ISA) Server 2000 with Feature Pack 1 passes logon information to a server that is running RSA ACE/Server by RSA Security, and the user name contains a space, authentication does not succeed, and an error message similar to the following will appear:
100: Access denied. The RSA ACE/Server rejected the passcode you supplied. Please try again.

CAUSE

When the Web Filter for authentication for RSA SecurID in ISA Server Feature Pack 1 passes a user name that contains a space to a server that is running RSA ACE/Server, the space character is replaced by a plus sign. For example, the server receives the user name "George Frank" as "George+Frank." This causes the server to deny authentication.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next ISA Server service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site: Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version       Size    File name
   ---------------------------------------------------
   05-May-2003  01:09  3.0.1200.267  81,680  Sdisa.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:10/11/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix KB331070 kbAudDeveloper