The SMTP Message Screener may not filter some messages correctly in ISA Server 2000 (331061)



The information in this article applies to:

  • Microsoft Internet Security and Acceleration Server 2000
  • Microsoft Internet Security and Acceleration Server 2000 SP1

This article was previously published under Q331061

SYMPTOMS

When you use the Internet Security and Acceleration (ISA) Server 2000 Simple Mail Transfer Protocol (SMTP) Message Screener to filter e-mail messages, the SMTP Message Screener may not filter some messages correctly.

CAUSE

This problem occurs if the ISA Server SMTP Message Screener filters multipart messages.

In Microsoft Outlook, e-mail messages and attachments are split into multipart messages if the total size of the message is too large to be sent as a single message. When an e-mail message and an attachment are split into multipart messages, the file names and the file extensions are changed from the original file names and file extensions. Therefore, some of the rules that you created may not function correctly. For example, rules that you created to delete attachments that contain .exe file extensions do not function correctly because the multipart messages are assigned new file extensions. The ISA Server SMTP Message Screener does not detect the original extensions. Therefore, the ISA Server SMTP Message Screener does not filter the messages.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for ISA Server 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

313139 How to obtain the latest Internet Security and Acceleration Server 2000 service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next ISA Server 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time      Version       Size    File name     Platform
   -------------------------------------------------------------------
   22-Oct-2002  14:25:24  3.0.1200.180  60,176  Fltrsnk1.dll  x86
   22-Oct-2002  14:25:28  3.0.1200.180  93,968  Fmtpfltr.dll  x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in ISA Server 2000 Service Pack 1.

Modification Type:MinorLast Reviewed:9/30/2005
Keywords:kbHotfixServer kbQFE kbQFE kbbug kbfix KB331061 kbAudDeveloper kbAudITPRO