An Office program stops responding, and you receive an error message that references the Hpbafd32.dll file (330903)



The information in this article applies to:

  • Microsoft Office Professional Edition 2003
  • Microsoft Office Standard Edition 2003
  • Microsoft Office Students and Teachers Edition 2003
  • Microsoft Office Small Business Edition 2003
  • Microsoft Office Basic Edition 2003
  • Microsoft Office Access 2003
  • Microsoft Office Excel 2003
  • Microsoft Office FrontPage 2003
  • Microsoft Office OneNote 2003
  • Microsoft Office Outlook 2003
  • Microsoft Office PowerPoint 2003
  • Microsoft Office Publisher 2003
  • Microsoft Office Word 2003
  • Microsoft Office XP Application Error Report
  • Microsoft Office XP Developer
  • Microsoft Office XP Professional
  • Microsoft Office XP Small Business
  • Microsoft Office XP Standard
  • Microsoft Office XP Students and Teachers
  • Microsoft Access 2002
  • Microsoft Excel 2002
  • Microsoft FrontPage 2002
  • Microsoft Outlook 2002
  • Microsoft PowerPoint 2002
  • Microsoft Publisher 2002
  • Microsoft Visio 2002 Standard
  • Microsoft Word 2002
  • Microsoft Office 2000 Developer
  • Microsoft Office 2000 Premium
  • Microsoft Office 2000 Professional
  • Microsoft Office 2000 Small Business
  • Microsoft Office 2000 Standard
  • Microsoft Access 2000
  • Microsoft Excel 2000
  • Microsoft FrontPage 2000
  • Microsoft Outlook 2000
  • Microsoft PowerPoint 2000
  • Microsoft Publisher 2000
  • Microsoft Word 2000
  • Microsoft Office 97 for Windows
  • Microsoft Office 97 Professional Edition for Windows
  • Microsoft Office 97 Small Business Edition for Windows, version 2.0
  • Microsoft Office 97 Standard Edition for Windows
  • Microsoft Access 97
  • Microsoft Excel 97 for Windows
  • Microsoft FrontPage 97 for Windows
  • Microsoft PowerPoint 97 for Windows
  • Microsoft Publisher 97
  • Microsoft Word 97 for Windows

This article was previously published under Q330903

Thank You for Your Help!

Microsoft thanks you for taking the time to send us information about the program error that you just experienced. After investigating error reports provided by users like you, our engineers devised a workaround for this problem. This article contains information that may help you avoid encountering this problem again in the future.

ERROR SIGNATURE

This article addresses a crash problem that can have the following error signatures:

App Name   App Version   Module Name   Module Version   Offset
----------------------------------------------------------------
appname    appversion    Hpbafd32.dll  4.2.1.3          000040ea
In this error signature, appname is the name of a Microsoft program, and appversion is the version of the program. Additionally, other offsets are possible.

SYMPTOMS

When you use one of the Microsoft Office programs that are listed in the "Applies to" section, you may receive an error message that is similar to the following:
Microsoft program has encountered a problem and needs to close. We are sorry for the inconvenience.

where program is the Microsoft program that you were working with when the error occurs.

To see what data this error report contains, click here.
When you view the data in the error report, the report contains an error signature that is similar to the error listed at the beginning of this article.

CAUSE

This problem occurs because the Hewlett-Packard Driver installation packages for both the 1200 and the 3200 printer models install the Hpafd32.dll file version 4.2.1.3 (time stamp 9/27/01), a shared component. When you install other Hewlett-Packard drivers on the system, the Hpafd32.dll file updates to either version 4.6.0.0 or version 4.7.0.0, both of which have a time stamp of 5/5/01 for the Hpafd32.dll file . Because the time stamp is 5/5/01 for both the 4.6.0.0 and the 4.7.0.0 versions, the Hpdafd32.dll file does not update as expected.

WORKAROUND

To work around this problem, download and run the installation for a more recent Hewlett-Packard printer driver, such as the 3300, the 4600, the 8150, the 9000, or the 4100 printer drivers. For more information, see Driver Downloads or Support at the following Hewlett-Packard Web site:

http://welcome.hp.com/country/us/eng/welcome.htm

MORE INFORMATION

For information about how to contact Hewlett-Packard, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and software vendor contact information, A-K

60781 Hardware and software vendor contact information, L-P

60782 Hardware and software vendor contact information, Q-Z



Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

The Office Error Reporting dialog box appears when an error occurs that results in a fatal event in the program. The dialog box includes a button to send the information about the fatal event to Microsoft. Microsoft gathers information about these types of events in a database to attempt to identify the cause. For more information about the Microsoft Data Collection Policy, visit the following Microsoft Web site: For additional information, click the following article numbers to view the following articles in the Microsoft Knowledge Base:

283768 Description of the end user privacy policy in application error reporting when you are using Office

289508 How to view error signatures if an Office program experiences a serious error and quits


Modification Type:MinorLast Reviewed:10/10/2006
Keywords:kbbug kbnofix kbProd2Web KB330903