"Could not access network location" error message when you install Visual Studio 2005 or Visual Studio .NET (330766)



The information in this article applies to:

  • Microsoft Visual Studio 2005 Standard Edition
  • Microsoft Visual Studio 2005 Professional Edition
  • Microsoft Visual Studio .NET (2003), Professional Edition
  • Microsoft Visual Studio .NET (2003), Enterprise Architect Edition
  • Microsoft Visual Studio .NET (2003), Enterprise Developer Edition
  • Microsoft Visual Studio .NET (2003), Academic Edition
  • Microsoft Visual Studio .NET (2002), Professional Edition
  • Microsoft Visual Studio .NET (2002), Enterprise Architect Edition
  • Microsoft Visual Studio .NET (2002), Enterprise Developer Edition
  • Microsoft Visual Studio .NET (2002), Academic Edition
  • Microsoft Windows CE 5.0

This article was previously published under Q330766
Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

You may receive one of the following error messages when you try to install software that is listed in the "Applies to" section:
Error 1606.Could not access network location

Windows components do not match the version required for Visual Studio .NET

Setup Failed the following component failed to install "Installation Runtime Files"

CAUSE

This problem may occur if you upgraded the operating system of the computer from an earlier version of Microsoft Windows to Microsoft Windows Server 2003, Microsoft Windows XP, or Microsoft Windows 2000. This problem occurs because the following registry entry is not removed from the registry when you upgrade the Microsoft Windows Millennium Edition operating system:

HKEY_Local_Machine\Software\Microsoft\Windows\Current Version\Explorer\User Shell Folders\Common Administrative Tools

RESOLUTION

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To resolve this problem, delete the following key from the registry.

HKEY_Local_Machine\Software\Microsoft\Windows\Current Version\Explorer\User Shell Folders\Common Administrative Tools

To delete the registry key, follow these steps:
  1. Click Start, and then click Run.
  2. In the Open text box, type Regedit, and then click OK.
  3. In Registry Editor, expand My Computer.
  4. Under HKEY_Local_Machine, locate the following registry key:

    HKEY_Local_Machine\Software\Microsoft\Windows\Current Version\Explorer\User Shell Folders\Common Administrative Tools

  5. Right-click the Common Administrative Tools key, and then click Delete.
  6. Click Yes to delete the key.

STATUS

This behavior is by design.

REFERENCES

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

304576 How to troubleshoot the Windows Component Update for Visual Studio .NET


811122 Error message: Windows files must be installed for your installation to proceed


320112 Installation of .NET Framework fails and requires manual removal


306905 Visual IDE does not open when started or application cannot start error message


Modification Type:MajorLast Reviewed:2/1/2006
Keywords:kbvs2005swept kbvs2005applies kbsetup kberrmsg kbprb KB330766 kbAudDeveloper