Visual Studio .NET 2003 Setup or Visual Studio 2005 Setup may fail when antivirus or firewall program is running (330733)



The information in this article applies to:

  • Microsoft Visual Studio .NET (2003), Enterprise Architect Edition
  • Microsoft Visual Studio .NET (2003), Enterprise Developer Edition
  • Microsoft Visual Studio .NET (2003), Academic Edition
  • Microsoft Visual Studio 2005 Professional Edition
  • Microsoft Visual Studio 2005 Standard Edition
  • Microsoft .NET Framework 1.1
  • Microsoft .NET Framework 2.0

This article was previously published under Q330733
Important This article contains information that shows you how to help lower security settings or how to turn off security features on a computer. You can make these changes to work around a specific problem. Before you make these changes, we recommend that you evaluate the risks that are associated with implementing this workaround in your particular environment. If you implement this workaround, take any appropriate additional steps to help protect your system.

SYMPTOMS

When you install Microsoft Visual Studio .NET 2003 or the .NET Framework version 1.1, or you install Microsoft Visual Studio 2005 or the .NET Framework version 2.0 on a computer running Microsoft Windows 2000, Windows XP, or Windows Server 2003, you may receive warnings during setup. If you ignore the messages, Visual Studio .NET or Visual Studio 2005 may install successfully. However, in certain cases, Setup may stop responding during installation or the installation may fail. If the installation fails, you may receive the following error message:
Error 1310.Error writing to file: Microsoft.VisualStudio.VCProjectEngine.dll. Verify that you have access to that directory.

CAUSE

This behavior occurs because an antivirus program, a firewall program, or a script blocking program is running during the installation of Microsoft Visual Studio .NET or of Microsoft Visual Studio 2005. Visual Studio .NET Setup or Visual Studio 2005 Setup has custom actions in Microsoft VBScript that stop responding or cause problems if you have antivirus script blockers (such as those in an antivirus program or a firewall program) turned on.

RESOLUTION

Warning This workaround may make your computer or your network more vulnerable to attack by malicious users or by malicious software such as viruses. We do not recommend this workaround but are providing this information so that you can implement this workaround at your own discretion. Use this workaround at your own risk.

To resolve this problem, quit the antivirus program or the firewall program before you install Visual Studio .NET 2003 or the .NET Framework version 1.1 or before you install Visual Studio 2005 or the .NET Framework version 2.0. To do this, follow these steps:

On a computer running Windows 2000

Important These steps may increase your security risk. These steps may also make your computer or your network more vulnerable to attack by malicious users or by malicious software such as viruses. We recommend the process that this article describes to enable programs to operate as they are designed to, or to implement specific program capabilities. Before you make these changes, we recommend that you evaluate the risks that are associated with implementing this process in your particular environment. If you choose to implement this process, take any appropriate additional steps to help protect your system. We recommend that you use this process only if you really require this process.
  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click Administrative Tools, and then double-click Services.
  3. Stop or turn off all antivirus, personal firewall, and other monitoring services:
    • To stop a service, right-click the service, and then click Stop.
    • To turn off the service, right-click the service, and then click Properties. In the Automatic Updates Properties dialog box, set the Startup type to Disabled.


    Note If you stop the services, they start again automatically when you restart the computer. If you turn off the services, you must manually turn them on again after you install Visual Studio .NET.

On a computer running Windows XP or Windows Server 2003

  1. Click Start, and then click Run.
  2. In the Open text box, type MSConfig, and then click OK.
  3. On the General tab of the System Configuration Utility dialog box, click to clear the check boxes for all antivirus, personal firewall, and other monitoring services.
  4. Click Apply, and then click Close.
  5. Restart the computer when you receive the prompt.

Note After you install Visual Studio .NET or Visual Studio 2005, return to MSConfig, click to select all check boxes that were unselected in step 3, and then restart the computer.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

When you run an antivirus program while Setup is running, you may receive warning messages from the antivirus program. These warnings may occur while Microsoft Visual Studio .NET Setup or the .NET Framework version 1.1 Setup, or Microsoft Visual Studio 2005 Setup or the .NET Framework version 2.0 Setup runs scripts that gain access to file system objects. You can safely ignore the alerts and continue to run the Setup scripts. Typically, Visual Studio .NET or Visual Studio 2005 installs successfully.

However, your firewall program may interfere with configuration of some services during setup of Microsoft Visual Studio .NET or the .NET Framework version 1.1, or during setup of Microsoft Visual Studio 2005 or the .NET Framework version 2.0 because Visual Studio .NET Setup or Visual Studio 2005 Setup has VBScript custom actions that stop responding when antivirus script blockers are turned on.

For example, during the configuration process, Setup stops and then restarts Internet Information Services (IIS). Your firewall program may cause Visual Studio .NET Setup or Visual Studio 2005 Setup to stop responding during configuration of IIS because Setup interacts with IIS. This behavior may prevent Setup from correctly configuring some services such as the World Wide Web Publishing service, the FTP Publishing service, and the Simple Mail Transfer Protocol (SMTP) service.

Script blocking can be turned on regardless of whether the script block program or service is running. You may have to turn off the script blocking from within the script blocking program. Sometimes, you must remove the script blocking program. However, the removal operation may fail to remove the script blocking. If this problem occurs, you must use a special removal script from the program's manufacture to remove the script block.

For more information about known installation issues for Microsoft Visual Studio .NET 2003 or Microsoft Visual Studio 2005, see section 5 of the Readme.htm file that is located on CD1 of Microsoft Visual Studio .NET 2003 or Microsoft Visual Studio 2005. Section 5.27, "Setup may fail when antivirus and personal firewall software are running" also includes this issue.

REFERENCES

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

319714 How to troubleshoot Visual Studio .NET installation

321434 Firewall software may cause a Visual Studio .NET installation to stop responding (hang)

312116 Disable Symantec ScriptBlocker before you install Visual Studio .NET

306905 Visual IDE does not open when started or application cannot start error message

304576 How to troubleshoot the Windows Component Update for Visual Studio .NET


Modification Type:MajorLast Reviewed:3/3/2006
Keywords:kbvs2005applies kbvs2005swept kbPubTypeKC kbMSCCSearch kbvirus kbFSO kbsetup kberrmsg kbprb KB330733 kbAudDeveloper