The Processor Performance State Is Not Restored to the Maximum State If the CPU Runs at 100 Percent (330512)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition SP1
  • Microsoft Windows XP Professional SP1
  • Microsoft Windows XP Media Center Edition
  • Microsoft Windows XP Tablet PC Edition
  • Microsoft Windows XP 64-Bit Edition Version 2002
  • Microsoft Windows XP 64-Bit Edition Version 2002 SP1

This article was previously published under Q330512

SYMPTOMS

The processor performance state may not be restored to the maximum state if the CPU runs at 100 percent. This problem occurs if the computer is 100 percent busy when the power policy changes.

CAUSE

This problem may occur if the power policy changes because of an AC/DC transition while the computer is using the "Max Battery" power scheme. When the computer is running at 100 percent CPU usage, the computer never enters the idle loop in which the speed of the CPU is dynamically adjusted based on demand and current policy values. The fix is to set the timer so that Windows changes the speed of the CPU when the timer expires.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size       File name     Platform  SP
   --------------------------------------------------------------------------
   09-Nov-2002  14:09  5.1.2600.105      32,000  Amdk6.sys     x86       none
   09-Nov-2002  14:09  5.1.2600.105      32,512  Amdk7.sys     x86       none
   09-Nov-2002  14:09  5.1.2600.105      31,488  Crusoe.sys    x86       none
   21-Nov-2002  01:37  5.1.2600.107   1,848,320  Ntkrnlmp.exe  x86       none
   21-Nov-2002  01:38  5.1.2600.107   1,902,080  Ntkrnlpa.exe  x86       none
   21-Nov-2002  01:38  5.1.2600.107   1,874,944  Ntkrpamp.exe  x86       none
   21-Nov-2002  01:37  5.1.2600.107   1,879,936  Ntoskrnl.exe  x86       none
   09-Nov-2002  14:09  5.1.2600.105      36,992  P3.sys        x86       none
   09-Nov-2002  14:09  5.1.2600.105      30,592  Processr.sys  x86       none
   09-Nov-2002  10:16  5.1.2600.1142     32,000  Amdk6.sys     x86       1
   09-Nov-2002  10:16  5.1.2600.1142     32,512  Amdk7.sys     x86       1
   09-Nov-2002  10:16  5.1.2600.1142     31,488  Crusoe.sys    x86       1
   19-Nov-2002  01:20  5.1.2600.1143     30,976  Gv3.sys       x86       1
   08-Dec-2002  20:31  5.1.2600.1149  1,892,352  Ntkrnlmp.exe  x86       1
   08-Dec-2002  20:31  5.1.2600.1149  1,948,288  Ntkrnlpa.exe  x86       1
   08-Dec-2002  20:31  5.1.2600.1149  1,921,024  Ntkrpamp.exe  x86       1
   08-Dec-2002  20:31  5.1.2600.1149  1,924,480  Ntoskrnl.exe  x86       1
   25-Nov-2002  21:59  5.1.2600.1145     37,632  P3.sys        x86       1
   09-Nov-2002  10:16  5.1.2600.1142     30,592  Processr.sys  x86       1
   21-Nov-2002  01:38  5.1.2600.107   5,734,400  Ntkrnlmp.exe  IA64      none
   21-Nov-2002  01:38  5.1.2600.107   5,677,568  Ntoskrnl.exe  IA64      none
   09-Nov-2002  16:34  5.1.2600.105      60,032  Processr.sys  IA64      none
   08-Dec-2002  20:31  5.1.2600.1149  5,791,744  Ntkrnlmp.exe  IA64      1
   08-Dec-2002  20:31  5.1.2600.1149  5,734,912  Ntoskrnl.exe  IA64      1
   09-Nov-2002  11:26  5.1.2600.1142     60,032  Processr.sys  IA64      1

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

Modification Type:MinorLast Reviewed:10/11/2005
Keywords:kbHotfixServer kbQFE kbWinXPsp2fix kbQFE kbbug kbfix kbWinXPpreSP2fix KB330512