SNA Server Does Not Process Data That Is Received from the PVI Interface (330328)



The information in this article applies to:

  • Microsoft SNA Server 4.0
  • Microsoft SNA Server 4.0 SP1
  • Microsoft SNA Server 4.0 SP2
  • Microsoft SNA Server 4.0 SP3
  • Microsoft SNA Server 4.0 SP4
  • Microsoft Host Integration Server 2000
  • Microsoft Host Integration Server 2000 SP1

This article was previously published under Q330328

SYMPTOMS

An application that is written for the Advanced Program-to-Program Communication (APPC) interface may stop responding intermittently.

CAUSE

In the sample that is discussed in this article, the problem is caused by an incoming LUSTAT negative response. The most significant bit of the sequence number is set in error.

RESOLUTION

SNA 4.0

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next SNA service pack that contains this fix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
	Date         Time      Version            Size    File name
--------------------------------------------------------------
29-Oct-2002  13:45     4.0.0.606       468,864    Snaservr.exe     
29-Oct-2002  13:45     4.0.0.606       935,344    Trcservr.exe    
			
NOTE: Because of file dependencies, the most recent fix that contains the above files may also contain additional files.
Host Integration Server 2000
A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next SNA service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version            Size    File name
--------------------------------------------------------------
08-Nov-2002  18:08  5.0.0.900       471,312    Snaservr.exe
08-Nov-2002  18:08  5.0.0.900     1,024,272    Trcservr.exe    
			
NOTE: Because of file dependencies, the most recent fix that contains the above files may also contain additional files.

WORKAROUND

You may be able to work around this problem by enhancing the "Minimum Contention Winner Session Limit" for outgoing conversations in the "Limit" section of the appropriate APPC Mode settings.

If no Contention Winner Sessions are available, SNA Server queries the remote system to find out if it is permitted to open a Bracket. This is completed by sending a LUSTAT request with the Begin Bracket Bit set. This eventually causes the error when the negative response is returned. This scenario does not occur if enough Contention Winner Sessions are available. SNA Server can then open a session immediately instead of prompting the remote system, thereby avoiding the problem.

STATUS

Microsoft has confirmed that this is a problem in Microsoft SNA Server version 4.0, all Service Packs and Host Integration Server 2000, all Service Packs.

MORE INFORMATION

When SNA Server Data Link Traces are enabled, an output similar to the following may appear:
DLC   ----------------------------------------------- 13:50:29.0144
DLC   01020101->04160000 DLC DATA
DLC                      DAF:02 OAF:04 ODAI:off Normal
DLC                      LUSTAT RQD DFC FI BC EC DR1 QR  BB
DLC
DLC   ---- Header  at address 013154C0, 1 elements ----
DLC   1E010000 00002C00 020483EA 01002A01     <......,...c...*.>
DLC
DLC   ---- Element at address 01D0A448, start 10, end 17 ----
DLC   4B828004 00060000                       <Kb......        ><BR/>


DLC   ----------------------------------------------- 13:50:29.0191
DLC   04160000->01020101 DLC DATA
DLC                      DAF:04 OAF:02 ODAI:off Normal
DLC                      LUSTAT -RSP DFC FI SD BC EC DR1 QR
DLC
DLC   ---- Header  at address 01315CAC, 1 elements ----
DLC   04000004 10112C00 040283EA 0100F401     <......,...c...4.>
DLC                         ^^^^  
DLC   ---- Element at address 01D0AB20, start 10, end 17 ----
DLC   CF920008 14000004                       <.k......        >
				
Notice that the LUSTAT has responded with a negative response. However, view the sequence number that is indicated by ^^^^, which is 83EA. The first significant bit is set. According to IBM's Systems Network Architecture Formats Guide, Document Number GA27-3136, the LUSTAT Request unit, Bytes 4-5 indicate in Note C: Low-order 15 bits of the SNF in the BB request that is being responded to. The high-order bit identifies the sender of the BB request (0 = secondary, 1 = primary). Because the LUSTAT request has not been sent by the primary SNA Server, processing of later conversation data for this session stops.

Modification Type:MinorLast Reviewed:10/6/2005
Keywords:kbBug kbfix kbQFE KB330328 kbAudDeveloper