"STOP 0x0000007E" error message after you upgrade to Windows XP (330182)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

This article was previously published under Q330182

SYMPTOMS

After you upgrade your computer to Windows XP, you may receive the following STOP error message:
STOP: 0x0000007E (0xC0000005, 0x804E518E, 0xFC938104, 0xFC937E04)
SYSTEM_THREAD_EXCEPTION_NOT_HANDLED
Note The four parameters in this error message may vary depending on the cause of the STOP error.

CAUSE

This issue may occur if a system thread generates an exception that the error handler does not catch. This may occur if one or more of the following conditions exist:
  • If this issue occurs after the first restart during Windows Setup, or after Setup is finished, the computer may not have sufficient hard disk space to run Windows.
  • If this issue occurs after the first restart during Windows Setup, or after Setup is complete, the computer BIOS may be incompatible with Windows.
  • Incompatible video adapter drivers.
  • Damaged RAM.
  • A damaged device driver or system service.
  • If the issue is associated with the Win32k.sys file, it may be caused by a third-party remote control program.

RESOLUTION

To troubleshoot this issue, use the following methods.

Method 1: Make sure that you have sufficient hard disk space

Make sure that you have sufficient hard disk space. For problems during Windows installation that are associated with a lack of available hard disk space, you must free space on your hard disk. Delete any unnecessary temporary files, Internet cache files, program backup files, and .chk files that contain saved file fragments from disk scans. You can also use another hard disk with more free space for the installation.

Method 2: Update the computer BIOS

Make sure that your computer BIOS revision is current. Contact the computer manufacturer to obtain the latest BIOS update for the computer. You may have to temporarily disable BIOS memory options such as caching or shadowing.

For information about how to contact computer hardware manufacturers, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and Software Third-Party Vendor Contact List, A-K

60781 Hardware and Software Third-Party Vendor Contact List, L-P

60782 Hardware and Software Third-Party Vendor Contact List, Q-Z

Method 3: Disable or update device drivers

View the Microsoft Hardware Compatibility List (HCL) to determine if the PCI devices in the computer are compatible with Windows XP.

For additional information about how to obtain the latest Windows XP hardware compatibility list, click the following article number to view the article in the Microsoft Knowledge Base:

314062 The latest Windows XP Hardware Compatibility List

Update the video adapter drivers to the latest versions. If a driver is listed by name in the STOP error message, disable or remove that driver. Disable or remove any drivers or services that you recently added. If the error occurs during the startup sequence and the system partition is using the NTFS file system, you may be able to use Safe mode to rename or to delete the faulty driver. If the driver is used as part of the system startup process in Safe mode, you must start the computer by using the Recovery Console to use the file.

If the problem is associated with the Win32k.sys file, the problem may be caused by a third-party remote control program. To remove the service, use the Recovery Console to start the computer, and then delete the specified system service file.

Method 4: Remove unsigned drivers

If you cannot start Windows in Safe mode, remove all drivers that are not digitally signed by Microsoft.

For additional information about how to do this, click the following article number to view the article in the Microsoft Knowledge Base:

316434 How to perform advanced clean-boot troubleshooting in Windows XP

Method 5: Remove all third-party drivers

In rare cases, you may not be able to determine which third-party driver causes the error. To troubleshoot this issue, move all third-party driver files from the Windows\System32\Drivers folder to a different location. To do this, follow these steps:
  1. Use the Recovery Console to start the computer, or start the computer from a different installation of Windows if you have performed a parallel Windows installation.
  2. Move all files from the Windows\System32\Drivers folder that do not have a creation date for Windows XP of 8/13/2001. If the computer relies on a third-party IDE or SCSI controller driver for correct operation, you must identify those driver files, and then leave them in the Windows\System32\Drivers folder.
  3. Restart the computer.
  4. Continue the Windows Setup program.
For additional information about how to disable a service that prevents Windows from starting, click the following article number to view the article in the Microsoft Knowledge Base:

310602 How to disable a service or a device that prevents Windows from starting

MORE INFORMATION

If the following conditions are true, the issue may be a hardware incompatibility with Windows XP because all the installed drivers are Windows XP drivers:
  • You receive the STOP 0x7E error when you first start the computer.
  • You receive the STOP 0x7E error after you run the Setup program.
  • You did not install any third-party drivers during the installation of Windows.
However, if you receive the STOP 0x7E error after you upgrade from Windows 2000 Professional, or if you recently added a new hardware device, this issue may be an incompatible driver or an incompatible hardware device.

For additional information about related topics, click the following article numbers to view the articles in the Microsoft Knowledge Base:

315222 A description of the Safe Boot Mode options in Windows XP

314058 Description of the Windows XP Recovery Console

308041 Resources for troubleshooting startup problems in Windows XP

For additional information about other troubleshooting steps that you can use, click the following article number to view the article in the Microsoft Knowledge Base:

314063 Troubleshooting a Stop 0x0000000A error in Windows XP


Modification Type:MajorLast Reviewed:5/5/2004
Keywords:kbenv kberrmsg kbprb KB330182