Cannot Print After You Install Windows XP on Your Hewlett-Packard Pavilion 8380 Computer (330139)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

This article was previously published under Q330139

SYMPTOMS

After you install Windows XP on your Hewlett-Packard Pavilion 8380 computer, your printer may not print. In the Device Manager, the printer port LPT1 may display an exclamation mark, and may report the following error:
This device is disabled because the firmware for the device did not give it a required resource. (Code 29)

CAUSE

This issue may occur if improper BIOS communication with the LPT port occurs.

RESOLUTION

To resolve this issue, contact Hewlett-Packard to inquire about the availability of a BIOS update or fix for this issue. For information about how to contact Hewlett-Packard, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and Software Third-Party Vendor Contact List, A-K

60781 Hardware and Software Third-Party Vendor Contact List, L-P

60782 Hardware and Software Third-Party Vendor Contact List, Q-Z

Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

WORKAROUND

Warning If you are not sure about how to safely change BIOS settings, view your hardware documentation or contact Hewlett-Packard before you change the BIOS.

To work around this issue, configure your LPT port to use EPP or PS/2 printing instead of ECP in the BIOS. Also, if the parallel port is configured as "O/S controlled" in the BIOS, change this option to "enabled".

Modification Type:MinorLast Reviewed:4/29/2003
Keywords:kbprint kbprb KB330139