You receive a "Network write: The handle is invalid" error message when you use the Rsh.exe tool in Windows 2000 Server (330028)



The information in this article applies to:

  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional

This article was previously published under Q330028

SYMPTOMS

When you use the remote shell tool (Rsh.exe) at a command prompt on a Microsoft Windows 2000 Server-based computer, you may receive an error message that is similar to the following:
Network write: The handle is invalid.
You may have to press ENTER to return to the command prompt.

CAUSE

This problem may occur if the following conditions are true:
  • The rshexit process calls the TerminateThread function when the TerminalInputHandler thread is running.
  • The TerminalInputHandler thread owns a critical section object.
  • The TerminateThread function forces the TerminalInputHandler thread to close without releasing ownership of the critical section object.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows 2000 Server. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

260910 How to obtain the latest Windows 2000 Service Pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version        Size   File name
--------------------------------------------------- 
25-Oct-2002  02:33  5.0.2195.6104  4,096  Rsh.exe          
31-Oct-2002  04:03  5.3.7.0        4,096  Spmsg.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:10/10/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbQFE KB330028 kbAudEndUser kbAudITPRO