Cannot open a Web folder document that is located on a Microsoft Sharepoint Portal Server-based server (329919)



The information in this article applies to:

  • Microsoft Internet Explorer 6.0 SP1, when used with:
    • the operating system: Microsoft Windows XP
    • the operating system: Microsoft Windows 2000
    • the operating system: Microsoft Windows NT 4.0
    • the operating system: Microsoft Windows Millennium Edition
    • the operating system: Microsoft Windows 98 Second Edition
    • the operating system: Microsoft Windows 98
  • Microsoft Internet Explorer 5.5 SP2, when used with:
    • the operating system: Microsoft Windows 2000
    • the operating system: Microsoft Windows NT 4.0
    • the operating system: Microsoft Windows 98 Second Edition
    • the operating system: Microsoft Windows Millennium Edition
    • the operating system: Microsoft Windows 98

This article was previously published under Q329919

SYMPTOMS

When you try to locate a Web folder or open a Web folder document that is located on a Microsoft Sharepoint Portal Server-based server, you may receive the following error message:
The web folder address Internet Explorer was given is too long. Please use a shorter address
This problem occurs even after you install the hotfix that is described in the Microsoft Knowledge Base article 325355.

For more information about the hotfix, click the following article number to view the article in the Microsoft Knowledge Base:

325355 You cannot access Word documents by using Outlook Web Access on a server that is running SharePoint Portal Server

CAUSE

This problem occurs because of a hard-coded limit of 100 (MAX_WEB_FOLDER_LENGTH) for Web folder length. The fix described in Microsoft Knowledge Base article 325355 increases this limit to 260 (MAX_PATH). However, this limit may not be sufficient to handle a very long Web folder name. The hotfix described in this article permits Internet Explorer to handle a Web folder length of up to 2083 (INTERNET_MAX_URL_LENGTH).

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Internet Explorer 6 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To install the Internet Explorer 6 Service Pack 1 (SP1) version of this hotfix, you must be running Internet Explorer 6 SP1 (version 6.00.2800.1106) on Windows XP, Windows 2000 Service Pack 4 (SP4), Windows 2000 Service Pack 3 (SP3), Windows NT 4.0 Service Pack 6a (SP6a), or Windows Millennium Edition.

To install the Internet Explorer 5.5 version of this hotfix, you must be running Internet Explorer 5.5 SP2 (version 5.50.4807.2300) on Windows 2000 SP4, Windows 2000 SP3, Windows NT 4.0 SP6a, or Windows Millennium Edition.

Note Versions of Windows and versions of Internet Explorer that are not listed in this section are either in the extended phase of the product life cycle or are no longer supported. Although you can install some of the hotfix packages that are described in this article on these versions of Windows and of Internet Explorer, Microsoft has not tested these versions to assess whether this issue affects them or to confirm that the hotfix that is described in this article fixes the problem on those versions. Microsoft recommends that you upgrade to a supported version of Windows and of Internet Explorer, and then apply this hotfix. If you are running a version of Windows or of Internet Explorer that is in the extended phase of the product life cycle, and if you have an Extended Support Contract, contact your Technical Account Manager (TAM) or Applications Development Consultant (ADC) for information about a hotfix for your configuration.

For more information about how to determine what version of Internet Explorer you are running, click the following article number to view the article in the Microsoft Knowledge Base:

164539 How to determine which version of Internet Explorer is installed

For additional information about support life cycles for Windows components, visit the following Microsoft Web site: For more informationabout how to obtain Internet Explorer 6 SP1, click the following article number to view the article in the Microsoft Knowledge Base:

328548 How to obtain the latest service pack for Internet Explorer 6

For more informationabout how to obtain the latest service pack for Internet Explorer 5.5, click the following article number to view the article in the Microsoft Knowledge Base:

276369 How to obtain the latest service pack for Internet Explorer 5.5

Restart requirement

You must restart your computer after you apply this hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Internet Explorer 6.0 SP1
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   24-Oct-2002  09:03  6.0.2800.1132     231,424  Iepeers.dll      

			
Internet Explorer 5.5 SP2
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   28-Oct-2002  08:45  5.50.4922.2800    237,840  Iepeers.dll      
			

STATUS

Microsoft has confirmed that this is a problem in Microsoft Internet Explorer 6.

MORE INFORMATION

This fix discussed in this article is included in the versions of Internet Explorer 6 that are included with Windows Server 2003.

For more information about a related topic, click the following article number to view the article in the Microsoft Knowledge Base:

250807 Error message appears when you try to open a Web folder by using a Web address



The updates that are discussed in security bulletin MS05-014 change the limitation of the Web folder length (MAX_WEB_FOLDER_LENGTH) back to 100. However, you can apply the hotfix as described in Microsoft Knowledge Base article 325355 to increase this limit to 260 (MAX_PATH). For more information, click the following article number to view the article in the Microsoft Knowledge Base:

325355 You cannot access Word documents by using Outlook Web Access on a server that is running SharePoint Portal Server


Modification Type:MajorLast Reviewed:2/1/2006
Keywords:kbHotfixServer kbQFE kbbug kbfix kbIE600preSP2fix kbIE600sp2fix KB329919