Error Message Appears When You Try to Install Windows NT, Windows 95, or Windows 98 Printer Drivers on a Windows 2000 Server-Based Computer (329852)



The information in this article applies to:

  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Server

This article was previously published under Q329852

SYMPTOMS

When you try to install Microsoft Windows NT, Microsoft Windows 95, or Microsoft Windows 98 printer drivers (for Windows NT, Windows 95, or Windows 98 clients) on a Windows 2000 Server-based computer, the drivers do not install. You may receive an error message similar to the following, or you may be prompted for the location of a compatible driver:
The printer driver you selected is either not compatible with your current version of Windows, or it may not be available. Select a compatible driver from the list, or contact your administrator for help.

CAUSE

This problem may occur if the printer driver that is supplied by the printer manufacturer is not compatible with Windows 2000 Server or Windows 2000 Advanced Server.

Most Windows NT, Windows 95, and Windows 98 printer drivers can be installed on a Windows 2000 Server-based computer for use with client computers. However, there are several printer drivers that produce the symptoms that are described in this article.

This problem has been reported with some printer drivers for the following printers:
  • Hewlett-Packard LaserJet 1100
  • Hewlett-Packard LaserJet 2100
  • Hewlett-Packard LaserJet 8000
  • Hewlett-Packard LaserJet 8100
  • Xerox N32

RESOLUTION

To resolve this issue, contact the manufacturer of your printer for an updated driver or for a unified driver. A unified driver works with more than one operating system.

For information about how to contact the manufacturer of your printer, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and Software Third-Party Vendor Contact List, A-K

60781 Hardware and Software Third-Party Vendor Contact List, L-P

60782 Hardware and Software Third-Party Vendor Contact List, Q-Z



The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:5/27/2003
Keywords:kberrmsg kbprb KB329852