You Receive a "STOP 0x0000001E" Error Message When You Try to Log On to Your Exchange 2000 Server-Based Computer (329850)



The information in this article applies to:

  • Microsoft Exchange 2000 Server
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server

This article was previously published under Q329850
Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you try to log on to your Exchange 2000 Server-based computer, you may receive an error message that is similar to the following:
STOP 0x0000001E (0xc0000005,0x8051aebb,0x00000000,0x6f007e0f)

KMODE EXCEPTION NOT HANDLED NTOSKRNL.EXE 80518ebb80400000 384d5876-ntoskrnl.exe
If you analyze the memory dump file, you see a call stack that is similar to the following: bfcaba0c 8051aebb e1013008 ffffffff e1013008 ntkrnlmp!HvpGetCellPaged+0x35
bfcaba24 8051df08 e1013008 0021a300 e11020f4 ntkrnlmp!CmpFreeSecurityDescriptor+0x19
bfcaba40 8051e0ee e1013008 0021a300 e1232304 ntkrnlmp!CmpFreeKeyValues+0x66
bfcaba68 8051db09 e1013008 000ea0f0 e11020f4 ntkrnlmp!CmpSyncKeyValues+0x22
bfcabab4 8051d956 e24ba000 00000400 00000002 ntkrnlmp!CmpCopySyncTree2+0x1a3
bfcabae0 80511c1c e1013008 000001e0 e1013008 ntkrnlmp!CmpCopySyncTree+0x44
bfcabc44 8050e882 00010002 8050e82e 81f59508 ntkrnlmp!CmpSaveBootControlSet+0x1a8
bfcabc90 804624e9 00000004 00000000 e24b5fc8 ntkrnlmp!NtInitializeRegistry+0x54
bfcabc90 8042f863 00000004 00000000 e24b5fc8 ntkrnlmp!KiSystemService+0xc9
bfcabd0c 8050e84e 00000004 8050e82e 000a001f ntkrnlmp!ZwInitializeRegistry+0xb
bfcabd58 804624e9 00000004 00000000 00000000 ntkrnlmp!NtInitializeRegistry+0x20
bfcabd58 77f9a2e4 00000004 00000000 00000000 ntkrnlmp!KiSystemService+0xc9
0065fa2c 01004605 00000004 0065fa94 01016230 ntdll!ZwInitializeRegistry+0xb
0065fa70 010044e3 0065fabc 6e4f6373 0065faa8 services!ScAcceptTheBoot+0xca
0065fa90 77d8626c 00000000 00000001 02020202 services!RNotifyBootConfigStatus+0x7e
0065faac 77da3bca 0100447d 0065fac0 00000002 RPCRT4!NdrServerMarshall+0x12fa
0065fd10 77da3589 00000000 00000000 0065fdfc RPCRT4+0x63bca
0065fd2c 77d634a2 0065fdfc 0008e380 0065fdfc RPCRT4!NdrServerCall2+0x17
0065fd64 77d500de 010065fd 0065fdfc 0065fe40 RPCRT4!I_RpcBindingInqDynamicEndpointA+0x3044
0065fdbc 77d4ffb2 00000009 00000000 0065fe40 RPCRT4!I_RpcMapWin32Status+0x39f
0065fddc 77d56227 0065fdfc 00000000 0065fe40 RPCRT4!I_RpcMapWin32Status+0x273
0065fe44 77d56420 00000000 00116448 0010e4d0 RPCRT4!I_RpcTransDatagramFree+0x19f9
0065fe58 77d55db1 00000000 00000009 00000001 RPCRT4!I_RpcTransDatagramFree+0x1bf2
0065fe90 77d55671 00116430 00000003 00000009 RPCRT4!I_RpcTransDatagramFree+0x1583
0010e4d0 89abcdef 00000040 00000002 00000000 RPCRT4!I_RpcTransDatagramFree+0xe43
77d42078 77d55061 77d56876 77d5502c 77d54fc0 +0x89abcdef
77d491a9 c2042444 08c20004 74c98500 6a018b07 RPCRT4!I_RpcTransDatagramFree+0x833
2308418b 00000000 00000000 00000000 00000000 +0xc2042444

CAUSE

This problem may occur if a registry key in the Last Known Good control set is damaged. The system fails when it tries to clean up the Last Known Good control set to prepare to copy the current control set. This process makes the current control set the Last Known Good control set.

RESOLUTION

To resolve this problem, use Method 1 if you can obtain remote access to your computer. If you cannot do so, use Method 2.

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

Method 1: Remotely Edit the Registry

  1. Pause at the logon screen when you start the computer that is experiencing this problem. Do not log on to the computer.
  2. Remotely connect to the registry of this computer. To connect to a registry over a network:
    1. Start Registry Editor.
    2. On the File menu, click Connect Network Registry.
    3. In the Connect Network Registry dialog box, type the name of the computer to whose registry you want to connect.
  3. Locate the following registry key:

    HKEY_LOCAL_MACHINE\System\Select

    .
  4. Note the value of the LastKnownGood key.
  5. Change the value of the Failed key to the value that you noted in LastKnownGood.
  6. Note the value of the Current key.
  7. Change the value of the LastKnownGood key to the value you noted in Current plus one. For example, if Current has a value of 2, change the LastKnownGood value to 3.
  8. Quit Registry Editor.
  9. Restart the computer that you are trying to repair, and then log on to verify that the workaround is successful.
  10. Restart the computer, and then start Windows by using the Recovery Console. To do this:
    1. Start your computer with the Windows Setup floppy disks or with the Windows CD-ROM.
    2. At the "Welcome to Setup" screen, press R to repair a Windows installation.
    3. Press C to start the Windows Recovery Console. Type the number for the Windows installation that you want to repair, and then press ENTER.
    4. Type the administrator password, and then press ENTER.

      Note If you do not have an administrator password, just press ENTER.
  11. Change the current directory by typing the following command:

    cd system32\config

  12. Make a backup copy of the system hive by running the following command:

    copy system system.bak

  13. Quit the Recovery Console and restart the computer.
  14. Copy the System.bak file to a computer that is running Windows Server 2003 or Windows XP Service Pack 1 ( SP1).
  15. Start Registry Editor and use the Load Hive command to load the System.bak file.

    Note This will replace the corrupted registry with the registry you repaired in steps 2 through 7.
  16. Unload the hive and copy the System.bak file to the server it came from.
  17. Restart the computer, and then start Windows by using the Recovery Console.
  18. Type cd system32\config to change the current directory.
  19. Type ren system system.old to rename the current System file.
  20. Type copy system.bak system to set the System.bak file as the current System file.
  21. Type exit, and then press ENTER to restart your computer.

Method 2: Edit the Registry with a Parallel Installation of Windows 2000

  1. Perform a parallel installation of Windows 2000 on a separate partition on your computer.

    For additional information about how to perform a parallel installation, click the following article number to view the article in the Microsoft Knowledge Base:

    266465 HOW TO: Perform a Parallel Installation of Windows 2000

  2. Start your computer by using the new installation.
  3. Start Registry Editor.
  4. In the registry tree on the left, click either the HKEY_USERS key or the HKEY_LOCAL_MACHINE key.
  5. On the File menu, click Load Hive.
  6. In the Look in box, click the drive or folder that contains the system hive from the installation that has the problem. The system hive is located in the drive letter:\Winnt\System32\Config folder.
  7. Click SYSTEM, and then click Open.
  8. In the Key Name box, type the name that you want to assign to the hive, and then click OK.
  9. In the key that you just created, open the following registry key:

    HKEY_LOCAL_MACHINE\System\Select

    .
  10. Note the value of the LastKnownGood key.
  11. Change the value of the Failed key to the value that you noted in LastKnownGood.
  12. Note the value of the Current key.
  13. Change the value of the LastKnownGood key to the value you noted in Current plus one. For example, if Current has a value of 2, change the value of LastKnownGood to 3.
  14. On the Registry menu, click Save Key.
  15. Save the key to its original location in the drive letter:\Winnt\System32\Config folder. Save the file as SYSTEM without a file name extension.

Modification Type:MajorLast Reviewed:8/27/2003
Keywords:kberrmsg kbprb KB329850