SYMPTOMS
After the user has viewed the Windows Welcome (also known
as the "Out of Box Experience" or OOBE), the user may not see the
OEM-customized desktop wallpaper background. The user may see only a plain
desktop with icons displayed.
Note This problem occurs on Windows XP as follows:
- This issue occurs on Windows XP Home Edition only if the
customized wallpaper background is a JPEG (.jpg) file. Bitmap wallpaper files
(.bmp) do not cause this problem.
- This issue does not occur on Windows XP Professional Edition because the converted
bitmap is stored in the Administrator profile directory. This directory is not
deleted by Windows Welcome.
CAUSE
When the desktop wallpaper is customized, and if a JPEG
file is used, the operating system converts the file to a bitmap file (.bmp),
and then stores the bitmap file in the current user's profile directory. The
wallpaper file is always named Wallpaper1.bmp.
In the Audit mode of
Windows XP Home Edition, the file is stored in the following location:
%SystemDrive%\Documents and Settings\Owner\Local Settings\Application Data\Microsoft
During Windows Welcome (OOBE), the contents of the original Owner
profile directory are propagated to a newly created Owner profile directory,
and the original Owner account and profile directory are deleted. This is by
design. However, because the registry is still pointing to the original Owner
profile directory that no longer exists, the wallpaper is not
displayed.
RESOLUTION
Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows registry
Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
To work around this issue, use one of the following
methods to modify the registry:
- Method 1: Use Registry Editor.
- Method 2: Use a registry file (listed later in this
section).
Method 1: Use Registry Editor
After you apply the wallpaper that you want in Audit mode, and
before you run Sysprep.exe in reseal mode, modify the following registry
values:
- Start Registry Editor (Regedit.exe).
- Locate and then click the Wallpaper value
under the following key in the registry:
HKEY_CURRENT_USER\Control Panel\Desktop
- On the Edit menu, click
Modify, type the following, and then click
OK:
%USERPROFILE%\Local Settings\Application Data\Microsoft\Wallpaper1.bmp
- Locate and then click the
OriginalWallpaper value under the following key in the
registry:
HKEY_CURRENT_USER\Control Panel\Desktop
- On the Edit menu, click
Modify, type the following, and then click
OK:
%USERPROFILE%\Local Settings\Application Data\Microsoft\Wallpaper1.bmp
- Quit Registry Edit.
You can now run Syspre.exe in
reseal mode.
Method 2: Use a Registry File
Alternatively, you can update the registry by using the following
registry file:
Windows Registry Editor Version 5.00
[HKEY_CURRENT_USER\Control Panel\Desktop]
"Wallpaper"="%USERPROFILE%\\Local Settings\\Application Data\\Microsoft\\Wallpaper1.bmp"
"OriginalWallpaper"="%USERPROFILE%\\Local Settings\\Application Data\\Microsoft\\Wallpaper1.bmp"
Note Save the registry file as Fixwall.reg. By using the
%USERPROFILE% environment variable in the registry
entries, you make it possible for the OS to locate the file by evaluating the
variable and then providing the correct profile directory path of the wallpaper
bitmap file.
The registry file can be imported without user
intervention from a batch file by using the following syntax (assuming that the
registry file in this section was saved as Fixwall.reg):