Remote Access Server Intermittently Stops Responding (329470)



The information in this article applies to:

  • Microsoft Windows 2000 Advanced Server SP3
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Server SP3
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Server

This article was previously published under Q329470

SYMPTOMS

A Microsoft Windows 2000 server that is configured as a Routing and Remote Access server may intermittently stop responding (hang). When you perform additional troubleshooting, you notice the following symptoms:
  • No events appear in the system log or in the application log of Event Viewer to indicate the cause of this problem.
  • The server does not respond to PING requests.
  • You must cycle the power to the server or press the reset button to restore the server's functionality.

CAUSE

This issue may occur if the list that holds the frame buffers is corrupted. This issue may be caused by a bug in the AsyncMAC adapter, where AsyncMAC does not keep a reference count on its Asyncinfo block. A race condition may occur where an I/O Request Packet (IRP) request is completed by the serial driver after the Asyncinfo block is freed. In this case, a deadlock occurs.

RESOLUTION

This issue is resolved in Windows 2000 Service Pack 4 (SP4). To resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

260910 How to Obtain the Latest Windows 2000 Service Pack

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:

265173 The Datacenter Program and Windows 2000 Datacenter Server Product


Modification Type:MinorLast Reviewed:10/10/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbWin2000preSP4Fix KB329470 kbAudITPRO