XADM: You Cannot Recover the Security Key After a User Forgets the Password (329223)



The information in this article applies to:

  • Microsoft Exchange 2000 Server

This article was previously published under Q329223

SYMPTOMS

When you use the Advanced Security Key Management feature of Exchange 2000 to try to recover a key after a user forgets the password, the user is prompted for the password when he or she enters the new temporary key.

CAUSE

This problem occurs because the Exchange Server Administrator program generates a new temporary security key when you recover a security key.

The user must take the new temporary security key and in the Microsoft Outlook client, click Tools, click Options, click Security, and then set up advanced security.

When the user enters the recovered security token, the user is prompted for a password. That password is used to safeguard the user's digital ID. If the user forgets the password that he or she entered during the initial setup of advanced security, the user cannot continue to set up advanced security and cannot recover the security key.

WORKAROUND

To work around this problem, follow the steps that are outlined in the following article:

239551 XCLN: Recovering Key Management Server Digital ID Password

Although the Exchange 2000 help file states that administrators can use the Exchange Key Management Service (KMS) to recover the key if a user forgets the password, the steps described in "XCLN: Recovering Key Management Server Digital ID Password" are the only workaround.

You can reissue the security key for a mailbox if a user loses the password or corrupts or removes the local security information for the mailbox. From the user's perspective, this process is the same as the initial task of setting up advanced security.

STATUS

Microsoft has confirmed that this is a problem in Microsoft Exchange 2000 Server.

Modification Type:MinorLast Reviewed:4/25/2005
Keywords:kbbug KB329223