MSBBN: Other network devices are not displayed in the Broadband Network Utility (329125)



The information in this article applies to:

  • Microsoft Broadband Networking 10 100 Ethernet Notebook Adapter MN120
  • Microsoft Broadband Networking 10 100 Ethernet PCI Adapter MN130
  • Microsoft Broadband Networking 10 100 Ethernet USB Adapter MN110
  • Microsoft Broadband Networking Wireless Notebook Adapter MN520
  • Microsoft Broadband Networking Wireless USB Adapter MN510
  • Microsoft Broadband Networking Wireless Desktop Kit MN610
  • Microsoft Broadband Networking Wireless Notebook Kit MN620

This article was previously published under Q329125

SYMPTOMS

When you establish a peer-to-peer network between two computers, and both of the following conditions are true on one of the computers
  • A Microsoft Broadband network adapter is installed.

    -and-

  • The Microsoft Broadband Networking Utility program is installed.
other computers that are connected to your network are not displayed under Other Network Devices in the Broadband Network Utility (BNU).

NOTE: This issue does not affect the ability of these computers to interact normally on the network (for example, to share files). This issue concerns whether or not computers that are connected to your network are displayed under Other Network Devices in the BNU.

CAUSE

When you establish a peer-to-peer network between two computers, Windows uses Windows Automatic Private IP Addressing (APIPA) to configure TCP/IP settings. APIPA assigns addresses in the 169.254.x.y range, with a subnet mask of 255.255.0.0..

The BNU is configured to detect devices that are connected to the Microsoft Base Station, which has a subnet mask of 255.255.255.0. The BNU does not display devices with a subnet configured by APIPA at 255.255.0.0.

WORKAROUND

To work around this issue, use My Network Places to view computer resources connected to your network. To do this, follow these steps:
  1. Click Start, and then click My Network Places.

    NOTE: By default, My Network Places is located on the Start menu. However, it may be located on your desktop, or you can access it through Control Panel.
  2. Click Entire Network, and then double-click Microsoft Windows Network.
  3. Double-click the computer on which you want to view resources.

Modification Type:MinorLast Reviewed:1/7/2006
Keywords:kbprb KB329125