MSBBN: Computer stops responding when you disconnect and then reconnect a USB MN110 Ethernet adapter (329122)



The information in this article applies to:

  • Microsoft Broadband Networking 10 100 Ethernet USB Adapter MN110

This article was previously published under Q329122

SYMPTOMS

When you disconnect and then reconnect (hot plug) your MN110 Ethernet adapter to your computer's universal serial bus (USB) port, the computer may stop responding. Then, you have to restart the computer.

CAUSE

This issue may occur on computers that have either of the following VIA chip sets installed:
  • VIA 686B South Bridge
  • VIA 8233A South Bridge
Computers that have these chip sets installed may not receive a signal that the USB port is free. Therefore the computer behaves as though it is still connected to a device that is no longer connected. This is known as a ghost device. When another device or the same device is plugged in to that USB port, a conflict occurs. Therefore the computer stops responding.

RESOLUTION

To resolve this issue, visit the following VIA Technologies Web site for USB-related system updates: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

WORKAROUND

Note Perform this procedure before you try to reinstall a USB device. If you install a USB device through a USB port that is connected to a ghost device, this triggers a conflict that may cause the computer to stop responding.

To work around this issue, remove the ghost device that is causing the conflict. To do this, follow these steps:
  1. Click Start, right-click My Computer, and then click Properties.
  2. Click the Hardware tab, and then click Device Manager.
  3. Right-click any USB device that is not connected to the computer, and then click Delete.
  4. Repeat step 3 until you remove all the ghost devices.
Note If you do not want to remove the ghost device, you may be able to plug your device into a different USB port after you disconnect it.

Modification Type:MinorLast Reviewed:1/7/2006
Keywords:kbprb KB329122