SMS: A User32.dll Initialization Error May Occur When a Screen Saver Starts (329079)



The information in this article applies to:

  • Microsoft Systems Management Server 2.0
  • Microsoft Systems Management Server 2.0 SP1
  • Microsoft Systems Management Server 2.0 SP2
  • Microsoft Systems Management Server 2.0 SP3
  • Microsoft Systems Management Server 2.0 SP4
  • Microsoft Systems Management Server 2.0 SP5

This article was previously published under Q329079

SYMPTOMS

If your Systems Management Server (SMS) client computer that is running the Remote Tools Client agent (this is the Remote Control component) also has a screen saver configured, you may receive an error message that is similar to the following error message:
ScreenSaverName - DLL initialization failure.
Initialization of the dynamic link library C:\Windows\System32\User32.dll failed. The process is terminating abnormally.
This problem occurs on Microsoft Windows NT 4.0, Microsoft Windows 2000, and Microsoft Windows XP, but is most likely to occur on Windows NT 4.0-based computers. The problem typically occurs when the screen saver tries to start, and occurs only for users without administrator permissions on the computer.

CAUSE

This problem occurs because Wuser32.exe may not correctly clean up desktop handles.

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Systems Management Server service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site: NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix for SMS 2.0 Service Pack 4 (SP4) sites has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size       File name           Platform
   --------------------------------------------------------------------------
   01-May-2002  22:25                        65  Compverremctrl.ini  x86
   01-May-2002  22:25  2.0.92.9       1,371,494  Remctrl.exe         x86
   01-May-2002  22:25  2.0.1493.4204    265,792  Wuser32.exe         x86
The English version of this fix for SMS 2.0 Service Pack 5 (SP5) sites has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size       File name           Platform
   --------------------------------------------------------------------------
   25-Feb-2003  17:20                        67  Compverremctrl.ini  x86
   25-Feb-2003  17:20  2.0.92.10      1,351,404  Remctrl.exe         x86
   25-Feb-2003  17:20  2.0.1493.5137    265,792  Wuser32.exe         x86
Note Because of file dependencies, the most recent hotfix or feature that contains these files may also contain additional files.

How to Install the Hotfix

Using the Hotfix Installer

Note This method is only for Intel-based computers.
  1. Create a folder in a location that is accessible to your SMS site servers.
  2. Copy the update file (Sms2.0-kb329079-spN-x86-enu.exe, where N is the service pack version) and platform folders to the new folder. You must arrange the folder structure so that the update file is located one folder "above" the platform folders.
  3. From each of the primary and secondary SMS site servers in your environment, log on to your site server by using an account with administrator permissions.
  4. Quit the SMS Administrator console if it is running.
  5. Run Sms2.0-kb329079-spN-x86-enu.exe, and then follow the instructions in the wizard.

Performing a Manual Installation

  1. Create a folder in a location that is accessible to your SMS site servers.
  2. Copy the platform folders that contain the hotfix files to the new folder.
  3. From each of the primary and secondary SMS site servers in your environment, log on to your site server by using an account with administrator permissions.
  4. Quit the SMS Administrator console if it is running.
  5. Stop all SMS services.
  6. Replace the Remctrl.exe file in the SmsRootFolder\Inboxes\Clicomp.src\Remctrl\Platform folder with the version from the hotfix.
  7. Replace the Compver.ini file in the SmsRootFolder\Inboxes\Clicomp.src\Remctrl folder with the CompverRemctrl.ini file from the hotfix. You must rename the CompverRemctrl.ini file to Compver.ini.
  8. Restart the SMS services.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:4/14/2006
Keywords:kbQFE kbHotfixServer kbSMS200preSP6fix kbfix kbbug KB329079