XADM: Error Message "-939523539", Information Store Service Does Not Start (328640)



The information in this article applies to:

  • Microsoft Exchange Server 5.5

This article was previously published under Q328640

SYMPTOMS

After you restore Exchange Server from an online backup, the Information Store service may not start. You receive the following error message:
Windows could not start the Microsoft Exchange Information Store on Local Computer. For more information, review the System Event log. If this is a non-Microsoft service, contact the service vendor, and refer to service-specific error code -939523539
The following event ID messages are logged in Application event log and the System event log. System Event log

Event Type:	Error
Event Source:	Service Control Manager
Event Category:	None
Event ID:	7024
Date:		8/30/2002
Time:		10:52:32 PM
User:		N/A
Computer:	ServerName
Description:
The Microsoft Exchange Information Store service terminated with service-specific error 3355443757.


Application Event log
Event Type:	Error
Event Source:	ESE97
Event Category:	Logging/Recovery 
Event ID:	153
Date:		8/30/2002
Time:		10:51:29 PM
User:		N/A
Computer:	ServerName
Description:
 (904) The restore log file 0xx is missing.
Event Type:	Error
Event Source:	MSExchangeIS
Event Category:	Recovery 
Event ID:	1080
Date:		8/30/2002
Time:		10:51:29 PM
User:		N/A<BR/>
Computer:	ServerName
Description:
Unable to recover the database because error 0xc800022d occurred after a restore operation. The data is not fully restored because some log files are missing.
Event Type:	Error
Event Source:	MSExchangeIS
Event Category:	General 
Event ID:	5000
Date:		8/30/2002
Time:		10:51:29 PM
User:		N/A
Computer:	ServerName
Description:
Unable to initialize the Microsoft Exchange Information Store service. Error 0xc800022d.

CAUSE

Service Specific Error 0xc800022d is translated to JET_errMissingRestoreLogFiles.

This error message is recorded if old transaction logs exist and they are not in sequence with the restored log files. These log files are not required for hard recovery to complete. Even if the restore was successful and log files from Backup and the current log files are in sequence, the old log files prevent hard recovery.

RESOLUTION

  1. Start Registry Editor.
  2. Locate the following key in the registry:

    HKEY_LOCAL_MACHINE\System/CurrentControlSet/Services/MSExchangeIS/Restore in Progress

  3. Write down the values of HighLog Number and LowLog Number of the Restore in Progress key.
  4. In the Transaction logs folder, delete all log files that are older than the LowLog Number (lower LGeneration).
  5. Start the Information Store service.

Modification Type:MinorLast Reviewed:4/28/2005
Keywords:kbprb KB328640