Background pages are not displayed in Metadata previews (328047)



The information in this article applies to:

  • Microsoft Visio 2002 Standard
  • Microsoft Visio 2002 Professional

This article was previously published under Q328047

SYMPTOMS

When you view the metadata information for each page in a Visio drawing file, the first page preview is shown with additional preview images of changes that were made during previous edits of the first page. Additionally, background page previews are not shown at all for any of the pages.

NOTE: You have to have a third-party or custom program to view this additional metadata. With Microsoft Visio, you can save a preview picture of one or all of the pages in the file; however, Visio displays only a preview of the first page if you use click Preview on the Views menu in the File Open dialog box.

CAUSE

The list that is formulated to sort the pages by foreground pages first and background pages returns the expected page ID for only the first background page and only if the drawing is made up only of background pages. Also, the previews are not reinitialized correctly when a subset of pages is edited. This results in the updated metafile previews of the pages being appended to the existing previews.

RESOLUTION

Service pack information

This problem is corrected in Visio 2002 Service Pack 2.

To resolve this problem, obtain the latest service pack for Visio 2002. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

867749 How to obtain the latest Visio 2002 Service Pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Visio 2002 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
The global version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date          Time       Size        File name      
   -------------------------------------------------
   09-Sep-2002   5:06 PM    2,658,304   Q328047.msp
				
After the hotfix is installed, the following files will have the listed file attributes or later:
   Date          Time        Version        Size        File name
   ---------------------------------------------------------------
   09-Sep-2002   4:06 PM     10.0.3305.4    68,832      visio.exe
   09-Sep-2002   4:06 PM     10.0.3305.4    6,348,008   vislib.dll
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
This problem was first corrected in Visio 2002 Service Pack 2.

MORE INFORMATION

For more information about about file properties, type about Visio file summary properties in the Ask a question box or the Answer Wizard, and then press ENTER to view the topics.

Modification Type:MinorLast Reviewed:7/27/2006
Keywords:kbHotfixServer kbQFE kbbug kbfix kbQFE KB328047