The enumeration process for serial devices cannot recognize a serial modem that is connected to a hot-plug serial interface device in Windows 2000 (327868)



The information in this article applies to:

  • Microsoft Windows 2000 Advanced Server SP3
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Server SP3
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Professional SP3
  • Microsoft Windows 2000 Professional SP2
  • Microsoft Windows 2000 Professional SP1

This article was previously published under Q327868

SYMPTOMS

When you connect a serial modem to a hot-plug serial interface controller (RS-232) on a Microsoft Windows 2000-based computer, the enumeration process for serial devices (Serenum.sys) may not recognize the modem.

CAUSE

This problem occurs when the Routing and Remote Access service tries to connect to a discovered modem while the Serenum.sys service is enumerating the COM port that is connected to the hot-plug serial interface controller. In this case, the Serenum.sys service locks the port during the enumeration process. Therefore, Routing and Remote Access cannot connect to the device.

Note Serenum.sys is the Windows 2000 filter driver that enumerates serial devices.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
   Date         Time   Version            Size    File name
   -----------------------------------------------------------
   03-Oct-2002  17:48  5.0.2195.6078      14,160  Serenum.sys
   03-Oct-2002  17:49  5.0.2195.6078      60,880  Serial.sys
   13-Jun-2001  05:05  5.0.2195.3727       3,856  Svcpack1.dll     

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the following article number to view the article in the Microsoft Knowledge Base:

265173 The Datacenter program and Windows 2000 Datacenter Server product

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

REFERENCES

For more information about the enumeration process for serial devices in Windows, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:10/10/2005
Keywords:kbHotfixServer kbQFE kbWin2000preSP4Fix kbbug kbfix KB327868 kbAudITPRO kbAudEndUser