FIX: Repeatedly Retrieving Remote Performance Counters May Fail with Status 1450 (327795)



The information in this article applies to:

  • Microsoft .NET Framework

This article was previously published under Q327795

SYMPTOMS

When you repeatedly retrieve performance counters on a remote computer, the PerformanceCounter class may fail with status 1450, and you may receive the following error message:
Insufficient system resources exist to complete the requested service.

CAUSE

This error occurs because performance counters are implemented by using the RegistryKey class. When your program gains access to remote performance counters, the PerformanceCounter class calls Microsoft.Win32.RegistryKey.OpenRemoteBaseKey.

Remote registry keys are opened as System keys. There is a bug in the .NET Framework that does not close these System keys when you are finished with them. Because there is a limit of 65,535 open System keys, when your program gains access to remote performance counters more than 65,535 times, you receive the error message in the "Symptoms" section.

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next .NET Framework service pack that contains this fix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version       Size       File name
   --------------------------------------------------------------
   10-Aug-2002  15:51  1.0.3705.302  1,860,000  Mscorlib.dll
   10-Aug-2002  05:21  1.0.3705.302  2,160,000  Mscorsvr.dll
   10-Aug-2002  05:22  1.0.3705.302  2,160,000  Mscorwks.dll
   10-Aug-2002  05:14                   10,000  Mscorlib.ldo
   10-Aug-2002  05:22  1.0.3705.302     64,000  CORPerfMonExt.dll
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:10/7/2005
Keywords:kbbug kbfix kbNetFrame100preSP3fix KB327795 kbAudDeveloper