"General Protection Fault!" Error Message When You Try to Play a Game of Harry Potter and the Sorcerer's Stone (327789)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

This article was previously published under Q327789

SYMPTOMS

When you try to start and play the Electronic Arts game Harry Potter and the Sorcerer's Stone in Windows XP or Windows XP with Service Pack 1 (SP1), you may receive the following error message:
General protection fault!

History: glxDetectOutput <- UGalaxyAudioSubsystem::Init <- UEngine::InitAudio <- UGameEngine::Init <- InitEngine

CAUSE

This behavior may occur if Aureal A3D drivers are installed on your computer, and the drivers conflict with an audio device that is installed on or connected to your computer.

RESOLUTION

To work around this problem, do one of the following, as appropriate to your situation:
  • Remove (uninstall) the Aureal A3D drivers from the computer. For more information about how to do this, see the product documentation or contact your sound card manufacturer.

    -or-
  • Select an audio device other than the Aureal device to use as the default sound device. To do this, follow these steps:
    1. Click Start, and then click Control Panel.
    2. Click Sounds, Speech, and Audio Devices.
    3. Click Sounds and Audio Devices, and then click the Audio tab.
    4. Under Default device, click the sound device that you want to use as the default device.
    5. Click OK, and then close the Sounds, Speech, and Audio Devices dialog box.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For information about how to contact your sound card manufacturer, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and Software Third-Party Vendor Contact List, A-K

60781 Hardware and Software Third-Party Vendor Contact List, L-P

60782 Hardware and Software Third-Party Vendor Contact List, Q-Z

Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:4/28/2003
Keywords:kbbug kberrmsg kbnofix KB327789