An Automation error occurs after a long COM call (327605)



The information in this article applies to:

  • Microsoft Visio 2002 Standard SR-1
  • Microsoft Visio 2002 Professional SR-1

This article was previously published under Q327605

SYMPTOMS

If the following conditions exist, Visio may increase CPU usage, and eventually fault or generate an Automation (RPC) error:
  1. Visio is in a synchronous COM call to an out-of-process server from a VBA macro or event.
  2. The server takes a long time to respond. For example, 3-30 minutes.
  3. The server tries to call back to Visio before the server returns from the synchronous call.

CAUSE

When Visio receives various events such as WM_ONACTIVATE from the operating system or programs, Visio times events that are implemented to refresh the state of Visio and the supporting components. These timed Visio tasks interfered with critical code path execution in the support components that Visio uses, and placed the Microsoft Visual Basic ActiveX control into the state where the critical failure would occur. The fix in this article makes a change to timed task so that they only start when Visio is handling idle events. These changes prevent Visio from interrupting this critical code execution.

RESOLUTION

Service pack information

This problem is corrected in Microsoft Visio 2002 Service Pack 2.

To resolve this problem, obtain the latest service pack for Microsoft Visio 2002. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

867749 How to obtain the latest Visio 2002 service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
If you are using Microsoft Windows 2000, you must obtain and install Windows 2000 Service Pack 3 (SP3), or obtain the fix in 324034.

For additional information about how to obtain the fix in 324034, click the following article number to view the article in the Microsoft Knowledge Base:

324034 INFO: Availability of Windows 2000 Post-Service Pack 2 COM+ Hotfix


The global version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version      Size     File name
   ----------------------------------------------------
   09-Aug-2002  10:31  10.0.3205.4  6347496  Vislib.dll 
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
This problem was first corrected in Visio 2002 Service Pack 2.

Modification Type:MinorLast Reviewed:7/27/2006
Keywords:kbHotfixServer kbQFE kbenv kbQFE kbbug kbfix KB327605