"Error 678 - There was no answer" intermittent error message when you try to complete a VPN connection from your Windows 2000-based computer (326816)



The information in this article applies to:

  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server

This article was previously published under Q326816

SYMPTOMS

When you use Point-to-Point Protocol (PPP) to make a virtual private network (VPN) connection that uses both Layer 2 Tunneling Protocol (L2TP) and Internet Protocol security (IPSec), you may receive the following error message after you try to connect to the VPN server:
Error 678 - There was no answer
This problem may occur intermittently after the initial successful connection. For example, the problem may have the following pattern:
  1. Your first attempt to connect to the PPP server is successful.
  2. Your second attempt to connect to the PPP server is not successful, and you receive the "Error 678" error message. You click Cancel, and then you try to dial again.
  3. Your third attempt to connect to the PPP server is successful.
  4. Your fourth attempt to connect to the PPP server is not successful, and you receive the "Error 678" error message. You click Cancel, and then you try to dial again.
  5. Your fifth attempt to connect to the PPP server is successful.
  6. Your sixth attempt to connect to the PPP server is not successful, and you receive the "Error 678" error message. You click Cancel, and then you try to dial again.

CAUSE

This problem occurs because the WinLogon component closes the PPP connection before it closes the VPN connection.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

260910 How to obtain the latest Windows service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

File information

Prerequisites


There are no prerequisites for installing this fix.

Restart information


You must restart your computer after you apply this hotfix.

Hotfix information


This hotfix does not replace any other hotfixes. The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   10-Sep-2002  19:23  5.0.2195.5265      42,256  Basesrv.dll      
   10-Sep-2002  19:23  5.0.2195.5907     222,992  Gdi32.dll        
   10-Sep-2002  19:23  5.0.2195.6011     708,880  Kernel32.dll     
   10-Sep-2002  19:23  5.0.2195.4733     332,560  Msgina.dll       
   13-Jun-2001  05:05  5.0.2195.3727       3,856  Svcpack1.dll     
   26-Jun-2001  02:17  3.10.0.103         47,808  User.exe
   10-Sep-2002  19:23  5.0.2195.6000     379,664  User32.dll       
   10-Sep-2002  19:23  5.0.2195.5968     369,936  Userenv.dll      
   27-Aug-2002  01:07  5.0.2195.6033   1,642,320  Win32k.sys
   10-Sep-2002  19:20  5.0.2195.6053     179,472  Winlogon.exe     
   10-Sep-2002  19:23  5.0.2195.5935     243,472  Winsrv.dll       
   10-Sep-2002  19:23  5.0.2195.6011     708,880  Kernel32.dll     
   10-Sep-2002  19:23  5.0.2195.6033   1,642,320  Win32k.sys
   10-Sep-2002  19:23  5.0.2195.5935     243,472  Winsrv.dll       

				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows 2000 Service Pack 4.

MORE INFORMATION

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the following article number to view the article in the Microsoft Knowledge Base:

265173 The Datacenter program and Windows 2000 Datacenter Server product

For additional information about how to install multiple hotfixes with only one restart, click the following article number to view the article in the Microsoft Knowledge Base:

296861 How to install multiple Windows updates or hotfixes with only one reboot


Modification Type:MinorLast Reviewed:10/10/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbWin2000preSP4Fix KB326816 kbAudEndUser kbAudITPRO