PRB: Commerce Server 2002 Business Desk catalog refresh error message when port number has changed (326759)



The information in this article applies to:

  • Microsoft Commerce Server 2002

This article was previously published under Q326759

SYMPTOMS

When you click Refresh in the Catalog Editor module of BizDesk, you may receive the following error message:
An error occurred while refreshing the catalog cache for: http://computer_name/retail
Error number: 0X800C0005
No Description, No Source, No Help File, Help Context is 0

CAUSE

This problem might occur if the port number on the site has changed. The first time you view the site, an entry is added to the CatalogCache_Virtual_Directory table.

When you click Refresh in the Catalog Editor module, BizDesk reads the URL out of the CatalogCache_Virtual_Directory table, and then tries to refresh both of the URLs. If the port number has changed since the value was written to the table, the value in the table is wrong and you receive the error message.

RESOLUTION

Delete the row that contains the incorrect URL. To do this, follow these steps:
  1. Open SQL Enterprise Manager, and then locate the correct database for your commerce application.
  2. Expand this database, and then click Tables.
  3. Right-click the CatalogCache_Virtual_Directory table, and then click Open Table/Return all Rows.
  4. Determine which value is wrong.
  5. Click the gray area to the left of the row to select the whole incorrect row, and then press DELETE.
  6. Click YES to permanently delete this row.

Modification Type:MinorLast Reviewed:10/1/2004
Keywords:kberrmsg kbfix kbnofix kbpending kbprb KB326759