Explorer.exe Repeatedly Generates Access Violation Error Messages After You Log On (326572)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional

This article was previously published under Q326572

SYMPTOMS

After you log on, Explorer.exe may repeatedly generate access violation error messages. The access violation occurs in the Browseui.dll module. However, this symptom does not occur when you log on with administrator rights.

CAUSE

This problem may occur if one or more registry keys are inaccessible. The inability to obtain access to registry keys would run an errant code path that would always cause a fault. The fault occurs because the incorrect release method was being called on the object.

RESOLUTION

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

260910 How to Obtain the Latest Windows 2000 Service Pack

Hotfix Information

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

For Internet Explorer 5.01, the English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name
   --------------------------------------------------------
   29-Jul-2002  17:21  5.0.3502.5983  792,848  Browseui.dll
				
For Internet Explorer 5.5 Service Pack 2, the English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name
   --------------------------------------------------------
   02-Dec-2002  16:48  5.50.4924.200  814,864  Browseui.dll
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Windows 2000 Service Pack 4.

MORE INFORMATION

If the correct symbols are installed, the Drwtsn32.log file contains the following registry state and stack:
eax=00000006 ebx=7118c688 ecx=00000007 edx=00000001 esi=7113ead0 
edi=80004005
eip=71187da9 esp=00f8e088 ebp=00f8e10c iopl=0     nv up ei pl zr na po nc
cs=001b  ss=0023  ds=0023  es=0023  fs=0038  gs=0000      efl=00000246

browseui!CEMDBLog::SetRoot+11:
71187da9 83662000 and dword ptr [esi+0x20] (7113eb4c)},0x0

0:007> k
ChildEBP RetAddr  
00f8e088 7113e5a9 browseui!CEMDBLog::SetRoot+0x11
00f8e094 70bd1966 browseui!CEMDBLog::Initialize+0xd
00f8e10c 7113e341 SHLWAPI!IUnknown_AtomicRelease+0x17
00f8e10c 7113e341 browseui!CUserAssist::Initialize+0x29

00f8e124 7113e2ec browseui!CUserAssist::Initialize+0x29
00f8e12c 7113e262 browseui!CUserAssist_CI2+0x25
00f8e148 711287bb browseui!CUserAssist_CreateInstance+0x22
00f8e168 77a58661 browseui!CClassFactory::CreateInstance+0x43
00f8e1d8 77a582ca OLE32!CServerContextActivator::CreateInstance+0x1bb
00f8e1f4 77a584d3 OLE32!ActivationPropertiesIn::DelegateCreateInstance+0x4a
00f8e218 77a58447 OLE32!CApartmentActivator::CreateInstance+0x3a
00f8e234 77a57d88 OLE32!CProcessActivator::CCICallback+0x59
00f8e254 77a57c9f OLE32!CProcessActivator::AttemptActivation+0x2a
00f8e298 77a58403 OLE32!CProcessActivator::ActivateByContext+0x4a
00f8e2c0 77a582ca OLE32!CProcessActivator::CreateInstance+0x32
00f8e2dc 77a58376 OLE32!ActivationPropertiesIn::DelegateCreateInstance+0x4a
00f8e528 77a582ca OLE32!CClientContextActivator::CreateInstance+0x80
00f8e544 77a54518 OLE32!ActivationPropertiesIn::DelegateCreateInstance+0x4a
00f8ecb0 77a5431d OLE32!ICoCreateInstanceEx+0x26d
00f8ecd8 77a546ea OLE32!CoCreateInstanceEx+0x2b
				
NOTE: Note that the general registers may differ, but the crash occurs on the "and dword ptr [esi+0x20]" instruction.

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:

265173 The Datacenter Program and Windows 2000 Datacenter Server Product

For additional information about how to install multiple hotfixes with only one reboot, click the article number below to view the article in the Microsoft Knowledge Base:

296861 Use QChain.exe to Install Multiple Hotfixes with One Reboot


Modification Type:MinorLast Reviewed:10/11/2005
Keywords:kbHotfixServer kbQFE kbshell kbWin2kSP4fix kbbug kbenv kberrmsg kbfix kbWin2000preSP4Fix KB326572