Event IDs 4118 and 12004 appear in the Application log, and e-mail messages are not delivered to recipients in Exchange Server 5.5 (326446)



The information in this article applies to:

  • Microsoft Exchange Server 5.5

This article was previously published under Q326446

SYMPTOMS

On your Microsoft Exchange Server 5.5 computer, the following events appear in the Application log in Event Viewer:

Event 1Event ID: 4118
Event Source: MSExchangeIMC
Type: Error
Date: date
Time: time
User: N/A
Computer: computername
Description: An error was encountered while validating addresses. This error was returned from the operating system, or messaging software. As a result, the message in spool file filename failed to be delivered.

Event 2 Event ID: 12004
Event Source: MSExchangeIS
Type: Error
Date: date
Time: time
User: N/A
Computer: computername
Description: Error 80004005-F20000FF occurred while processing message <>. The archive filename is 'filename'.

CAUSE

This problem occurs if the following conditions are true:
  • An e-mail message is sent from the Internet to the Internet Mail Connector (IMC) on the Exchange Server 5.5 computer.
  • The e-mail address of that e-mail message is corrupted or incorrectly formed.
When this problem occurs, the e-mail message is discarded by the Internet Mail Connector. In this scenario, the e-mail message sender does not receive a non-delivery report (NDR). Additionally, other recipients that are specified in this e-mail message do not receive a copy of the e-mail message, nor do they receive an NDR.

RESOLUTION

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

This hotfix requires Exchange Server 5.5 Service Pack 4 (SP4). For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

191014 How to obtain the latest Exchange Server 5.5 Service Pack

Restart Requirement

You must restart your computer to apply the changes after you install this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   31-Jul-2002  22:11  5.5.2656.66       209,680  Imcmsg.dll       
   31-Jul-2002  22:11  5.5.2656.66       503,568  Msexcimc.exe     

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:

817903 New naming schema for Exchange Server hotfix packages


Modification Type:MinorLast Reviewed:10/13/2005
Keywords:kbHotfixServer kbQFE kbQFE kbbug kbExchange550preSP5fix kbfix KB326446 kbAudITPRO