An Access Violation Occurs in Lsass.exe While the Network Connections Are Being Prepared (326404)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional

This article was previously published under Q326404

SYMPTOMS

While Windows 2000 is starting, Lsass.exe may cause an access violation (code 0xC0000005) while the Preparing Network Connections screen appears. The computer is then automatically restarted. This problem may not occur every time you start your computer.

CAUSE

If auditing is turned on, audits can occur before the Event Log service starts. These audits are queued in memory. If the Security event log is full and is not set to overwrite when the log is full, the audits are discarded and the memory is freed. A synchronization problem that causes the access violation occurs during the process of freeing memory.

You can check the status of the Security event logs by starting Event Viewer from the Administrative Tools menu or folder. Right-click the Security log, and then click Properties. The current log file size, the maximum log file size, and the settings for when the maximum log file size is met are listed on the General tab. You can also modify the settings on this tab.

RESOLUTION

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

260910 How to Obtain the Latest Windows 2000 Service Pack

Hotfix Information

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version      Size       File name
   --------------------------------------------------------
   23-Jul-2002  02:01  5.0.2195.5781    123,664  Adsldp.dll
   23-Jul-2002  02:01  5.0.2195.5781    131,344  Adsldpc.dll
   23-Jul-2002  02:01  5.0.2195.5781     62,736  Adsmsext.dll
   23-Jul-2002  02:01  5.0.2195.5940    358,160  Advapi32.dll
   23-Jul-2002  02:01  5.0.2195.5265     42,256  Basesrv.dll
   23-Jul-2002  02:01  5.0.2195.5855     49,424  Browser.dll
   23-Jul-2002  02:01  5.0.2195.5943    135,952  Dnsapi.dll
   23-Jul-2002  02:01  5.0.2195.5595     96,016  Dnsrslvr.dll
   23-Jul-2002  02:01  5.0.2195.5722     45,328  Eventlog.dll
   23-Jul-2002  02:01  5.0.2195.5907    222,992  Gdi32.dll
   23-Jul-2002  02:01  5.0.2195.5859    145,680  Kdcsvc.dll
   04-Jun-2002  23:31  5.0.2195.5859    199,952  Kerberos.dll
   23-Jul-2002  02:01  5.0.2195.4928    708,880  Kernel32.dll
   15-Jul-2002  17:52  5.0.2195.5940     71,024  Ksecdd.sys

   23-Jul-2002  01:54  5.0.2195.5960    507,152  Lsasrv.dll
   23-Jul-2002  01:54  5.0.2195.5960     33,552  Lsass.exe
   23-Jul-2002  02:01  5.0.2195.4733    332,560  Msgina.dll
   18-Jul-2002  01:51  5.0.2195.5949    107,792  Msv1_0.dll
   23-Jul-2002  02:01  5.0.2195.5877    307,472  Netapi32.dll
   23-Jul-2002  02:01  5.0.2195.5932    360,208  Netlogon.dll
   23-Jul-2002  02:01  5.0.2195.5886    917,264  Ntdsa.dll
   23-Jul-2002  02:01  5.0.2195.5585    386,832  Samsrv.dll
   23-Jul-2002  02:01  5.0.2195.5951    129,296  Scecli.dll
   23-Jul-2002  02:01  5.0.2195.5951    302,864  Scesrv.dll
   23-Jul-2002  02:01  5.0.2195.5931    379,664  User32.dll
   23-Jul-2002  02:01  5.0.2195.5644    369,936  Userenv.dll
   23-Jul-2002  02:01  5.0.2195.5859     48,912  W32time.dll
   04-Jun-2002  23:32  5.0.2195.5859     57,104  W32tm.exe
   17-Jul-2002  20:45  5.0.2195.5948  1,642,416  Win32k.sys
   03-May-2002  20:31  5.0.2195.5731    178,960  Winlogon.exe
   23-Jul-2002  02:01  5.0.2195.5935    243,472  Winsrv.dll
   23-Jul-2002  02:01  5.0.2195.5944    125,712  Wldap32.dll
				

WORKAROUND

To avoid this problem, set the Security log file settings to overwrite when the logs become full.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Windows 2000 Service Pack 4.

MORE INFORMATION

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:

265173 The Datacenter Program and Windows 2000 Datacenter Server Product

For additional information about how to install multiple hotfixes with only one reboot, click the article number below to view the article in the Microsoft Knowledge Base:

296861 Use QChain.exe to Install Multiple Hotfixes with One Reboot


Modification Type:MinorLast Reviewed:10/11/2005
Keywords:kbHotfixServer kbQFE kbSecurity kbWin2kSP4fix kbbug kbfix kbWin2000preSP4Fix KB326404